Welcome to Steelbeasts.com

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

kiss4luna

Members
  • Content count

    8
  • Joined

  • Last visited

About kiss4luna

  • Rank
    Junior Member
  1. oh i found it. there is another graphic related issue i encountered weeks ago and i didn't realize that it's caused by an recent update of my anti virus software. before this i did several fresh reinstall of the display driver and nothing work. hours ago i figured it out and uninstalled the antivirus software and both the graphic issues are gone. thx.
  2. hi guys, due to some unknown display problem i restored my windows 10 to a refresh statue by the system's recovery function. and i reinstalled steel beasts pro pe 4.019. the problem now is when i try to switch the program to fullscreen mode, there will be an 'a d3d device has a non-zero reference count' error and it will exit. the log shows : [22:33:22,633] WARN : ------------------------------- [22:33:22,633] WARN : Steel Beasts Log File v4.019 [22:33:22,634] WARN : Wed Jun 28 22:33:22 201 / 18836 [22:33:22,634] WARN : ------------------------------- [22:33:22,634] WARN : +--+ MEMORY USAGE INFO (SteelBeasts START): [22:33:22,634] WARN : | | Process: 314 MB (0 % of 128.0 TB total, 128.0 TB free) 314 MB min/200 MB max [22:33:22,634] WARN : | | Physical: 5.1 GB (32 % of 15.9 GB total, 10.9 GB free) 5.0 GB min/5.1 GB max [22:33:22,634] WARN : +--+ Pagefile: 6.3 GB (33 % of 18.8 GB total, 12.5 GB free) 6.2 GB min/6.3 GB max [22:33:22,640] WARN : Could not look up file attributes for 'C:\Users\kiss4\AppData\Roaming\eSim Games\Steel Beasts\options\options.dat'. Error code: 2 [22:33:22,640] ERROR: Failed to open memory file 'C:\Users\kiss4\AppData\Roaming\eSim Games\Steel Beasts\options\options.dat'. Error code: 2 [22:33:28,944] WARN : Failed to open hot keys file file 'C:\Users\kiss4\AppData\Roaming\eSim Games\Steel Beasts\options\std.hkf'. Error code: 2 [22:33:41,903] ERROR: A D3D object has a non-zero reference count (meaning things were not properly cleaned up). This program will now exit. So any ideas about this? Thanks!
  3. Just got back home from a trip. Didn't realize that it would cause this. Updated to the 7.0 beta and now Steel Beasts roars. Thanks to all you guys.
  4. Hi guys, Thank you all for your help. I tried clean-reinstall the NVIDIA drivers and DirectX and did a dxdiag check, still the same problem. And here are the latest crash dump files, I tried to run in normal mode, safe mode and debug mode. They are all the same. https://www.dropbox.com/s/a2mbejgsiefbvn6/SBProPE64cm.exe.7688.dmp?dl=0 https://www.dropbox.com/s/tvq1lzeflh7x9kg/SBProPE64cm.exe.17676.dmp?dl=0 https://www.dropbox.com/s/byz47l2pxandncn/SBProPE64cm.exe.19376.dmp?dl=0 Other 2D/3D applications are normal. Thanks again for your help and hard work.
  5. lol sorry, my bad. There is no any error messages pop up during the procedure, it's almost the same with the previous language pack issue: click to run the program, it shows in task manager a few seconds then disappear, leaves nothing behind. However it does leaves a crashdump, hope it will help. Here they are: https://www.dropbox.com/s/ie6hjoy4pvjwvg0/SBProPE64cm.exe.1204.dmp?dl=0 https://www.dropbox.com/s/j88ot8q0afv7czf/SBProPE64cm.exe.20676.dmp?dl=0
  6. Windows 10 updated to 10.0.15063 build 15063. Steel Beasts Pro PE 4.0.19 and 4.0.10 both can not start properly. Problem is very much like the language pack issue in 4.0.6. Any thoughts?
  7. this solved the problem. thanks.
  8. Hi guys, Tried all your solutions above but none seems work for my Windows 10 64bit system. SBProPE64cm.exe exists a little while in the task manager and then it will gone. I don't want to change my OS language to English because there is too much work-related stuffs that need to be in my local language stats, and Steel Beasts 3.0 runs no problem at all. So I think maybe there should be a 4.1 patch to fix it? It seems totally the program itself screwed up.