Jump to content
Sign in to follow this  
GunSlinger

Weird SB 4.0 Mouse Issue

Recommended Posts

I have upgraded to the new 4.0 (thanks Ssnake and the rest of the Esim team) but now I have a weird issue where everything works fine for a while and then my mouse no longer works while looking through the gun sight.  In the the menus, turret, map everything is ok but it seems after about 20 min of play time the "cross hair" mouse cursor changes over to the "pointer arrow" cursor and I lose the ability to move the gun sight/slew the turret with the mouse.

Share this post


Link to post
Share on other sites

Hm. I haven't heard of a similar case. Can you run SB Pro PE in windowed mode for a while. Maybe there is an error message in the background that is stealing the application focus? In fullscreen mode it would not pop to the front. In windowed mode, it does.

Share this post


Link to post
Share on other sites

Well, that might depend on the turret, and the fire control system mode. Not all vehicles have powered traverse, so it could be intentional.

(IOW: Tell us more about the details)

Share this post


Link to post
Share on other sites

Win 10 64bit

GTX 980

 

This is happening with the M1A1/A2s in the stock tutorial missions (that's all I have played with so far in 4.0)

 

Played some more last night in Fullscreen.  When it did happen I alt tabbed back out to Desktop to see if there was anything going on and there was not.  The last instance of this occurring was immediately after getting killed when switching tanks.  When I get home tonight I will run it some more in Windowed mode to see if that remedies the issue.  Not ideal but neither is not being able to control the gun! :)  

Edited by GunSlinger

Share this post


Link to post
Share on other sites
9 hours ago, IrishHussar said:

I also had this problem. I fixed it by going into the controls menu and selecting or deselecting joystick. Hope this helps.

 

Thanks your tip fixed my issue.  Cheers .

Share this post


Link to post
Share on other sites
On 8/10/2016 at 5:18 PM, IrishHussar said:

I also had this problem. I fixed it by going into the controls menu and selecting or deselecting joystick. Hope this helps.

 

This solved the issue for me, but only once -- after a while, the same issue cropped up again, and no amount of toggling the "ignore joystick" checkbox seems to help. The issue isn't resolved even by restarting the game.

 

My impression is that this was triggered after using a vehicle without a powered turret (M113), after which I can no longer get the crosshair mouse cursor even on tanks with powered turrets (Leopards etc), but it could be that it is triggered by some amount of time as well like GunSlinger speculated above.

 

Edit: No, scratch that, today both the fix worked (at least for now), and I couldn't trigger the issue by using non-powered turrets.

Edited by tomi
Fix has worked ok today

Share this post


Link to post
Share on other sites

I just encountered this problem. I am using a razer mouse. I alt-tabbed and put in a USB drive and went back in game, now it refused to move my gunsight using my mouse. I've restarted my game a few times, unplugged the USB-drive and no difference. Checked the keys and I found something funny.

 

It's like the palmswitch (P) is inverted, if I hold down P on my keyboard I can move my gunsight around, if I release it. It's still again.

I tried the fix mentioned above and it solved it for me, checked deactivate joystick and then unchecked it again fixed it.

Share this post


Link to post
Share on other sites

I also encountered this. When I first installed version 4, I jumped in really quick to the tank range and it worked just fine.  Then a day later I went in and the mouse will not move the gunsight nor pan the player view when in a playable position.  I went through the various combinations of Controls settings and also reset to default.  After a computer restart it behaves normally now.

 

During the problem, when I would right-click the mouse would snap to the center of the view and then turn back into the mouse arrow and not turn into the yellowish-black cross.  It would behave normally in the Map screen.  The right mouse button would still lase.  I don't have a joystick attached to the PC, and it is a Win10 x64.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×