Jump to content
Sign in to follow this  
kiss4luna

SB Pro PE crashes on start [suspected graphics card driver issue]

Recommended Posts

Windows 10 updated to 10.0.15063 build 15063.

Steel Beasts Pro PE 4.0.19 and 4.0.10 both can not start properly. Problem is very much like the language pack issue in 4.0.6.

Any thoughts?

Share this post


Link to post
Share on other sites

Well, posting the exact text of all error messages goes a long way to understand what is going on. I can read your mind only by touch, not remotely from the other end of the globe.

Share this post


Link to post
Share on other sites

lol sorry, my bad.

 

There is no any error messages pop up during the procedure, it's almost the same with the previous language pack issue: click to run the program, it shows in task manager a few seconds then disappear, leaves nothing behind. However it does leaves a crashdump, hope it will help.

 

Here they are:

https://www.dropbox.com/s/ie6hjoy4pvjwvg0/SBProPE64cm.exe.1204.dmp?dl=0

https://www.dropbox.com/s/j88ot8q0afv7czf/SBProPE64cm.exe.20676.dmp?dl=0

Share this post


Link to post
Share on other sites

Thank you. Also, as described in the user manual's troubleshooting section, can you please try and start Steel Beasts in the "debug" mode and send us the corresponding debugLog.txt file?

Share this post


Link to post
Share on other sites
On 18.4.2017 at 8:49 AM, kiss4luna said:

Windows 10 updated to 10.0.15063 build 15063.

Steel Beasts Pro PE 4.0.19 and 4.0.10 both can not start properly. Problem is very much like the language pack issue in 4.0.6.

Any thoughts?

 

The crashdumps indicate a problem with Direct3D, so this is most likely NOT a language back issue.

 

Since both 4.019 and 4.010 are crashing for you now, I suspect you have a GFX card driver problem.

 

FYI, I'm running Win 10 15063 (aka "Creators Update") here for testing as well and all is fine, so it is not an issue tied to the Win 10 update itself. Maybe your automatic update settings have been changed, and some GFX driver has been installed "behind your back"? In any case, I'd check and re-install the GFX drivers. And also make sure NOT to run any "screen grabbers" or "overlay" or "beautifier" (ENB) etc...

Share this post


Link to post
Share on other sites

Hi guys,

 

Thank you all for your help.

I tried clean-reinstall the NVIDIA drivers and DirectX and did a dxdiag check, still the same problem.

And here are the latest crash dump files, I tried to run in normal mode, safe mode and debug mode. They are all the same.

https://www.dropbox.com/s/a2mbejgsiefbvn6/SBProPE64cm.exe.7688.dmp?dl=0

https://www.dropbox.com/s/tvq1lzeflh7x9kg/SBProPE64cm.exe.17676.dmp?dl=0

https://www.dropbox.com/s/byz47l2pxandncn/SBProPE64cm.exe.19376.dmp?dl=0

 

Other 2D/3D applications are normal.

Thanks again for your help and hard work.

Share this post


Link to post
Share on other sites

The dump files indicate you have RivaTuner/MSI Afterburner installed.

Disable, uninstall or update RivaTuner to v7.0.0.0b19.

Edited by mrivers

Share this post


Link to post
Share on other sites

Please let us know if any of the solutions have worked or not.  It could aid us in assisting others.

 

Thank you.

Share this post


Link to post
Share on other sites
On 4/25/2017 at 9:58 PM, mrivers said:

The dump files indicate you have RivaTuner/MSI Afterburner installed.

Disable, uninstall or update RivaTuner to v7.0.0.0b19.

 

Just got back home from a trip.

Didn't realize that it would cause this. Updated to the 7.0 beta and now Steel Beasts roars.

 

Thanks to all you guys.

Share this post


Link to post
Share on other sites

Thank you for the feedback, it'll be something to keep in mind if others report similar problems.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...