Jump to content
Sign in to follow this  
kiss4luna

can not play in fullscreen

Recommended Posts

hi guys,

 

due to some unknown display problem i restored my windows 10 to a refresh statue by the system's recovery function.

and i reinstalled steel beasts pro pe 4.019.

the problem now is when i try to switch the program to fullscreen mode, there will be an 'a d3d device has a non-zero reference count' error and it will exit.

the log shows :

 

 

[22:33:22,633] WARN : -------------------------------
[22:33:22,633] WARN : Steel Beasts Log File v4.019
[22:33:22,634] WARN : Wed Jun 28 22:33:22 201 / 18836
[22:33:22,634] WARN : -------------------------------
[22:33:22,634] WARN : +--+ MEMORY USAGE INFO (SteelBeasts START):
[22:33:22,634] WARN : |  | Process: 314 MB (0 % of 128.0 TB total, 128.0 TB free) 314 MB min/200 MB max
[22:33:22,634] WARN : |  | Physical: 5.1 GB (32 % of 15.9 GB total, 10.9 GB free) 5.0 GB min/5.1 GB max
[22:33:22,634] WARN : +--+ Pagefile: 6.3 GB (33 % of 18.8 GB total, 12.5 GB free) 6.2 GB min/6.3 GB max
[22:33:22,640] WARN : Could not look up file attributes for 'C:\Users\kiss4\AppData\Roaming\eSim Games\Steel Beasts\options\options.dat'. Error code: 2
[22:33:22,640] ERROR: Failed to open memory file 'C:\Users\kiss4\AppData\Roaming\eSim Games\Steel Beasts\options\options.dat'. Error code: 2
[22:33:28,944] WARN : Failed to open hot keys file file 'C:\Users\kiss4\AppData\Roaming\eSim Games\Steel Beasts\options\std.hkf'. Error code: 2
[22:33:41,903] ERROR: A D3D object has a non-zero reference
count (meaning things were not properly
cleaned up).

This program will now exit.

So any ideas about this?

 

Thanks!

Share this post


Link to post
Share on other sites

Usually a driver update will fix this. That may include going back one driver version, if you have the latest.

Share this post


Link to post
Share on other sites

Failing that, dll injectors (like SweetFX/ReShade) and/or overlays (RivaTuner/MSI Afterburner for example) can cause issues too.

Share this post


Link to post
Share on other sites

oh i found it.

there is another graphic related issue i encountered weeks ago and i didn't realize that it's caused by an recent update of my anti virus software. before this i did several fresh reinstall of the display driver and nothing work. hours ago i figured it out and uninstalled the antivirus software and both the graphic issues are gone.

thx.

Share this post


Link to post
Share on other sites

What antivirus software was it? I know Avast Pro has caused some extreme network glitches in multiplayer games before.

Share this post


Link to post
Share on other sites

Looks like the Sonic Studio (part of some ASUS computers' base installations) may prevent Steel Beasts from starting in fullscreen mode. At least we could identify it in one case. We don't know yet if this has something to do with an application-specific sound profile.

Share this post


Link to post
Share on other sites

I am getting the same error. Have not tried much in the way of trouble shooting yet, other than updating my video drivers , which did not solve the problem. Is there a .ini file I can edit to set my game back to non-fullscreen mode so I can get it to at least open?

 

[12:54:51,585] WARN : -------------------------------
[12:54:51,585] WARN : Steel Beasts Log File v4.023
[12:54:51,585] WARN : Sat Nov  3 12:54:51 201 / 2704
[12:54:51,585] WARN : -------------------------------
[12:54:51,585] WARN : +--+ MEMORY USAGE INFO (SteelBeasts START):
[12:54:51,585] WARN : |  | Process: 234 MB (0 % of 8.0 TB total, 8.0 TB free) 234 MB min/124 MB max
[12:54:51,585] WARN : |  | Physical: 5.1 GB (32 % of 15.9 GB total, 10.8 GB free) 5.1 GB min/5.1 GB max
[12:54:51,585] WARN : +--+ Pagefile: 5.5 GB (17 % of 31.9 GB total, 26.4 GB free) 5.4 GB min/5.5 GB max
[12:55:05,452] WARN : Failed to open hot keys file file 'C:\Users\home\AppData\Roaming\eSim Games\Steel Beasts\options\std.hkf'. Error code: 2
[12:56:03,804] WARN : +--+ MEMORY USAGE INFO (SteelBeasts END):
[12:56:03,804] WARN : |  | Process: 732 MB (0 % of 8.0 TB total, 8.0 TB free) 234 MB min/923 MB max
[12:56:03,804] WARN : |  | Physical: 5.4 GB (34 % of 15.9 GB total, 10.6 GB free) 5.1 GB min/5.7 GB max
[12:56:03,804] WARN : +--+ Pagefile: 5.8 GB (18 % of 31.9 GB total, 26.1 GB free) 5.4 GB min/6.3 GB max
[12:56:04,317] WARN : Done
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×