Jump to content
Sign in to follow this  
Mahzel

Crash on startup after receiving stick

Recommended Posts

Hello everyone,

 

so I'm facing a "small" problem here, SB crash on startup after installing my CmStick (firmware upgraded and license installed)

I still own a time-limited licence (both show up in CM and Web admin), and until yesterday everything was fine.

 

So today I decided to install my licence on the CmStick and suddenly the game crash on startup. Here are the things I ttied : 

-remove the stick to play with the time limited license : no luck

-run as admin, and with various compatibility things : no luck

-VC++ redistribuables should be up to date (I tried to reinstall them, but the installer won't let me as they are up to date)

-Checked multiple times that windows was up to date.

 

This is the error message from the event viewer : 

Quote

Nom de l’application défaillante SBProPE64cm.exe, version : 4.0.1.9, horodatage : 0x58ed2df8
Nom du module défaillant : ucrtbase.dll, version : 10.0.15063.413, horodatage : 0x5ba8b66e
Code d’exception : 0xc0000409
Décalage d’erreur : 0x0000000000072208
ID du processus défaillant : 0x9f4
Heure de début de l’application défaillante : 0x01d30ba5c8495a23
Chemin d’accès de l’application défaillante : H:\Program Files\eSim Games\SB Pro PE\Release\SBProPE64cm.exe
Chemin d’accès du module défaillant: C:\WINDOWS\System32\ucrtbase.dll
ID de rapport : feb9a82c-7616-4e4c-8304-093b7b97f712
Nom complet du package défaillant : 
ID de l’application relative au package défaillant : 

 

And this is the latest log from SB : 

Quote

[17:41:19,151] WARN : -------------------------------
[17:41:19,151] WARN : Steel Beasts Log File v4.019
[17:41:19,152] WARN : Wed Aug  2 17:41:19 201 / 2548
[17:41:19,152] WARN : -------------------------------
[17:41:19,152] WARN : +--+ MEMORY USAGE INFO (SteelBeasts START):
[17:41:19,152] WARN : |  | Process: 263 MB (0 % of 128.0 TB total, 128.0 TB free) 263 MB min/166 MB max
[17:41:19,152] WARN : |  | Physical: 4.4 GB (56 % of 7.9 GB total, 3.5 GB free) 4.3 GB min/4.4 GB max
[17:41:19,152] WARN : +--+ Pagefile: 5.5 GB (40 % of 13.8 GB total, 8.3 GB free) 5.4 GB min/5.5 GB max

 Latest dump attached.

 

Seeing the dll at fault I tried to delete/reinstall it, no luck, but not sure of my source (another computer from my house)

I'm not good at reading dumps, so maybe there's an info I'm missing.

The sfc /scannow show no error when running.

Antivirus is NOT running.

 

After checking the forums for info I sumbled upon a chinese language issue (well, I'm in French locale, but it worked fine until yesterday) and the VCC++ redistribuable issue (wich are up to date, and I'm hesitant to reinstall them as I don't see why the hell installing a licence on a CmStick could mess with those things, but if required I'll go through that.)

 

DxDiag attached for system specs (win 10 x64)

 

If anything more is required, please state so.

 

By advance, thank you for your help.

 

SBProPE64cm.exe.11892.dmp

DxDiag.txt

Share this post


Link to post
Share on other sites

Personally, I'm just as bad in reading memory dumps as most others. The programmers are largely on holiday, so, it may take a while before we can offer an adequate response. That being said, I don't think that the "ucrtbase.dll" is part of the Steel Beasts installation. So I'm wondering where it is coming from (part of the monitor/graphics card software)?

 

If you can identify where this belongs, then maybe updating that software package will already solve the issue.

 

 

I think that the arrival of the CodeMeter stick is pure coincidence (unless you can make Stell Beasts crash if it is plugged in, and not crash while it is plugged out). HOWEVER, maybe the Support@CodeMeter.com also has some advice.

Share this post


Link to post
Share on other sites

Well I had another thought wich was... Patch tuesday. So I'll wait for a developper advice before uninstalling/reinstalling anything.

I'm not in a hurry (despite the time limited licence :(  )

 

I agree that the stick was pure coincidence but;....

Edited by Mahzel

Share this post


Link to post
Share on other sites
5 hours ago, Rotareneg said:

Might be worth it to check that you're running the latest CodeMeter runtime, 6.50b.

I didn't, but updated and still nope :(

 

@pvtkramer : that's the thread that initially put me on tracks, but I don't have OneDrive running, that's odd....

Edited by Mahzel

Share this post


Link to post
Share on other sites

So, out of despair I unsinstalled everything (redistribuables and SB, but not CM) and after a reboot and a fresh install everything now works fine. Probably some corrupted files....

Back to the beasts :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...