Jump to content
Gibsonm

4.023 - Return of the Towing Bug?

Recommended Posts

Earlier today did a mission with Kanium.

 

I wasn't controlling either vehicle but it appears a Leo1 attempted to tow a M113, which should work based on the "can tow same or lighter vehicle" guidelines.

 

In the attached Client AAR at GR 251769 we see:

 

Mission time 39:15: Leo1 moves adjacent to M113 and they both start to move. There is the usual towing distance between them.

 

Mission time 39:40: Both vehicles are destroyed by something other than enemy fire and are very close together.

 

At least the two vehicles weren't catapulted several km away.

 

Pretty sure both clients that experienced the issue had workable "pings" to the server. The Leo and M113 were controlled by people in Europe and the server was there too.

 

Hasty Defence of Franninge v1_7452_122817MARKS-PC-2010642.aar

Edited by Gibsonm

Share this post


Link to post
Share on other sites

It sounds like the towing vehicle and towed vehicle were owned by two separate users.  To avoid the issue, the suggestion is that the the towing vehicle owner should be given the towed vehicle while towing.

 

Sometimes there can be a network issue, apparently depending on the connection of the two clients, which may cause this; the two owning participants have a conflict in the towing behavior, then the "catapult" is what happens after the issue is resolved.

 

But yest, we will look into it, I am only mentioning this so you know how to avoid the issue. :)

Share this post


Link to post
Share on other sites

I don't know, maybe we can file an enhancement request to let the cable snap (=break the towing relationship) rather than doing large position upodates?

Share this post


Link to post
Share on other sites

Snappin cables    nice.:)... ah the memories, digging out the ends in 2 feet of water and mud, or just not ever finding parts of the cable. Is there no length to the realism that this Sim will achieve? :)  Whats next, Turret Monsters? :):)

Share this post


Link to post
Share on other sites
44 minutes ago, 12Alfa said:

Snappin cables    nice.:)... ah the memories, digging out the ends in 2 feet of water and mud, or just not ever finding parts of the cable. Is there no length to the realism that this Sim will achieve? :)  Whats next, Turret Monsters? :):)

 

Well it might remove the push for dismounted crews when idiot drivers are injured by standing in the wrong spot relative to a cable(s) under load.

Share this post


Link to post
Share on other sites
4 hours ago, Volcano said:

It sounds like the towing vehicle and towed vehicle were owned by two separate users.  To avoid the issue, the suggestion is that the the towing vehicle owner should be given the towed vehicle while towing.

 

Sometimes there can be a network issue, apparently depending on the connection of the two clients, which may cause this; the two owning participants have a conflict in the towing behavior, then the "catapult" is what happens after the issue is resolved.

 

But yest, we will look into it, I am only mentioning this so you know how to avoid the issue. :)

 

Yes they were.

 

I did ask if the "towed" transferred ownership to the "tow-er" prior to them connecting and it seemed that didn't happen.

 

Agree that having both vehicles owned by the one person during towing is the preferred option. You can always give it back once you are at the destination and uncoupled.

 

I might volunteer to do CSS during Kanium and TGIF tomorrow and provide an update.

 

Edited by Gibsonm

Share this post


Link to post
Share on other sites

Looks like (based on one example to date - so its a small sample) having the one person control both does work.

 

This was during a mulitplayer event.

Share this post


Link to post
Share on other sites

Were some issues with leaving the pair unattended. Needed to nursemaid them sometimes to keep them on the road.

 

If left unattended, they tended to wander off and inflicted extra damage on the towed vehicle moving through forests, etc.

 

Luckily the repair zone fixed "everything" so this added damage was rectified.

 

If it wasn't a magic repair zone, this extra damage would not have been fixed.

 

Edited by Gibsonm

Share this post


Link to post
Share on other sites

Just an update from last week's TGIF.

 

This now seems to at least sometimes happen even when both the tower and the towee are owned by the same player:

 

 

Unsure if that was a network lag / sync issue courtesy of the Multi-player / Internet aspect or the underlying issue.

 

Edited by Gibsonm

Share this post


Link to post
Share on other sites

It seems like certain road types create oscillation between the two vehicles. We have a bug report for this, and a reference scenario to replicate the bug. IOW, best conditions to get this fixed.

Share this post


Link to post
Share on other sites

UPDATE:

 

Not sure how far they need to travel to create the oscillation but here is the sequence:

 

Hitching up (1:51:39):

40896715265_578c95ee4d_c.jpg

 

First vehicle disappears (1:51:50):

26927623327_f552f4f3e5_c.jpg

 

Second one disappears (1:51:53):

26927623637_9877a85d95_c.jpg

 

 

Edited by Gibsonm

Share this post


Link to post
Share on other sites

I was towing one of my platoon mates vehicle out of danger today and all was well until he left his vehicle for another.  The vehicle he left moved violently for a moment and caused my towing vehicle to be jerked very hard.

 

I have recorded it should you want to see it.

Share this post


Link to post
Share on other sites

Was it on a road perchance?

 

On 4/30/2018 at 9:09 AM, Ssnake said:

It seems like certain road types create oscillation between the two vehicles. We have a bug report for this, and a reference scenario to replicate the bug. IOW, best conditions to get this fixed.

 

Share this post


Link to post
Share on other sites

No.  We were on top of a hill and he got tracked.  I towed him off so he would not be an artillery target.

Share this post


Link to post
Share on other sites

It would be more useful to have two vehicles towing offroad on that same hill, as a reference case. If there's a way how you can make this jerk happen reliably, that would be infinitely helpful. Even if you can't make it happen AT ALL and you describe the ways in which you tested that (test mode, single player, network session), it would be helpful. We can still take it from there with our test tools, like forcing a certain frame rate and/or network lag to see if it happens only under specific circumstances over which you have no control.

We already have one such "minimal repeat case" on roads; having one off-road would be a nice complement. And the most promising way to get there is by creating a scenario on the very same hill where you observed it (it could be, after all, a thing with the terrain itself). Also, just because we have one such scenario doesn't mean that all our bases are covered; it's entirely possible that there are two different bugs at work that manifest the same way (e.g. one is related to roads, the other (only) happens off-road, who knows).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...