Jump to content
sage0035

confused on what lisence I need to buy here

Recommended Posts

please help?? I have a first generation stick. what do I need to purchase from the store to be able to play 4.x?

Edited by sage0035

Share this post


Link to post
Share on other sites

It depends on what version your old license is for.  If you have a license for 2.5 or newer you just need to get the $40.00 upgrade.  If your license is older then you need the $80.00 upgrade.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...