Jump to content
Sign in to follow this  
RHK111

Saitek X-55 Throttle - can´t mapping from control menu I have SOLUTION

Recommended Posts

Any months ago I purchased new SB PRO PE 4.X version. I detected that my Saitek X-55 Throttle was not detected by new version of SB. In control options menu It´s impossible maped throttle buttons (only stick maping work). I don´t know why you can maping or Stick or Throttle, but not both of them ?!?!
I spent many time for solution of this issue; edited "Profiles" on Sitek program etc., but SB (in Win admin mode) still not detect throttle with (Saitek) "Profile" activated etc.
Now I think I have solution for use Saitek HOTAS (stick and throttle), I change "Switch Mode" (on throttle base - M1, M2, M3) to M2 and programed Throttle in this mode. Now is possible to overlap SB controls with activate Saitek Profile. You can maping Stick in SB control menu only, but for use Throttle you need maping it with Saitek Profile Editor in MODE 2 or 3 - MODE1 lock throttle buttons (in Steel Beasts).
I hope that eSimGames can fix this issue to be able to map both devices from control menu. In DCS and other Simulators / videogames I´ve never had those problems and my X-55 and previous X-52 have always worked perfectly. At this point and in the XXI century that should not happen: 

I have Win7 x64 Ultimate, but I think the same thing happens to Saitek X-55 in Win 10.

 

Best Regards.

 

RHK111


 

Edited by RHK111

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...