Jump to content
Botas

Steel Beasts Gold on VirtualBox question

Recommended Posts

I'm running the original Steel Beasts on a virtual XP machine inside VirtualBox and while it runs great the frame rate is capped at 50fps. It runs at 50fps regardless of mission complexity so it's not a lack of horsepower, and both my host PC and the virtual XP machine have their monitor refresh rates set to 60hz so I would expect it to run locked at 60fps.

 

Was this 50fps limit a feature of the original Steel Beasts or is something holding it back?

 

Is there a setting within VirtualBox I might have missed?

Share this post


Link to post
Share on other sites
1 hour ago, Botas said:

I'm running the original Steel Beasts on a virtual XP machine inside VirtualBox and while it runs great the frame rate is capped at 50fps. It runs at 50fps regardless of mission complexity so it's not a lack of horsepower, and both my host PC and the virtual XP machine have their monitor refresh rates set to 60hz so I would expect it to run locked at 60fps.

 

Was this 50fps limit a feature of the original Steel Beasts or is something holding it back?

 

Is there a setting within VirtualBox I might have missed?

You can try using PCem. Seems some are getting good resaults...

https://pcem-emulator.co.uk/

 

I havent tried niether so that all I can help with.

 

Edited by Red2112

Share this post


Link to post
Share on other sites

The 50 Hz limit is some weird VirtualBox thing. You can use DxWnd to run Steel Beasts directly at full performance, but you'll have to set a certain tweak in DxWnd to avoid tanks being rendered oddly while playing. Unfortunately, that tweak will also cause the mission editor to fail when loading a mission.

 

I tried setting up a Win98 install with PCem on my laptop and managed only 5 or so FPS in SB, your mileage may vary. :D I haven't tried other virtual machines, VMWare for instance, so it's possible some other VM might run it better than VirtualBox.

Share this post


Link to post
Share on other sites

Thanks for the info!

 

I tried the PCEM thing with a Win-95 install but it failed at the last hurdle. I was then tempted to try a Win-98 version but reading Rotareneg's experience I thought better of it.

 

I've tried DxWnd a few times but can't even get SB to launch.

Share this post


Link to post
Share on other sites
On 25/08/2018 at 2:37 AM, Bond_Villian said:

I should be in sales!

Talk to *Liquid snake voice* SSSSSSSSSSSSsnaaaaaaaaaaaaaaaake!

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...