Jump to content
Sign in to follow this  
Apocalypse 31

Baseline Scenarios Missing Legacy Maps (hmap basemap) [RESOLVED]

Recommended Posts

The following scenarios won't load due to missing legacy map.

 

Classic Scenarios

Are They Attacking Here (Leo 1A5)

Are They Attacking Here (Leo 2A4)

Are They Attacking Here (Leo 2A5)

Deliberate Assault 1

Deliberate Assault 2

Hasty Defense (US Modified)

 

Contest 1

Deliverance

 

Contest 2

Defense of Kozda

 

Multiplayer Scenarios

Domfessel 2013

 

Single Player Scenarios

PzGren Defense

 

sce2.png

Share this post


Link to post
Share on other sites
Posted (edited)

If they are looking for a .raw height map, then I suspect you likely have the old versions of the scenarios for some reason. They were updated to use the new maps. The updated missions should have installed with the rest of SB Pro PE.

Edited by TankHunter

Share this post


Link to post
Share on other sites
29 minutes ago, TankHunter said:

If they are looking for a .raw height map, then I suspect you likely have the old versions of the scenarios for some reason. They were updated to use the new maps. The updated missions should have installed with the rest of SB Pro PE.

Weird.

 

The folders were created today - but the files are from 2015. 

Share this post


Link to post
Share on other sites

Odd, are you sure you installed all the map packages from the map package installer?  Install them again if not.

 

But looking at the scenarios, which open here, try looking in your map package folder for these maps that some of the scenarios in your list use:

 

...\maps\packages\hmap [autocreated base]\deltas\sce_Domfessel 2013

...\maps\packages\hmap [autocreated base]\deltas\sce_Kozda

 

That is just two of the ones in your list off the top of my head that you can check to see if your map is present. These two maps are in the map installer.

Share this post


Link to post
Share on other sites
Posted (edited)
6 minutes ago, Volcano said:

...\maps\packages\hmap [autocreated base]\deltas\sce_Domfessel 2013

...\maps\packages\hmap [autocreated base]\deltas\sce_Kozda

I have both of those. 

C:\ProgramData\eSim Games\Steel Beasts\maps\packages\hmap [autocreated base]\deltas

 

Edit - for some reason there's nothing in my hmap folder though. what the heck?

Edited by Apocalypse 31

Share this post


Link to post
Share on other sites

Where are you accessing the scenarios from? Is it from "C:\ProgramData\eSim Games\Steel Beasts\scenarios" or is it from another path?

Share this post


Link to post
Share on other sites
Just now, TankHunter said:

Where are you accessing the scenarios from? Is it from "C:\ProgramData\eSim Games\Steel Beasts\scenarios" or is it from another path?

Yes.

 

C:\ProgramData\eSim Games\Steel Beasts\scenarios

Share this post


Link to post
Share on other sites

Ah OK, interesting. The Base map package is missing. I will throw something together here for you to try in a minute.

 

 

 

 

 

 

Share this post


Link to post
Share on other sites
Just now, Volcano said:

Ah OK, interesting. The Base map package is missing. I will throw something together here for you to try in a minute.

I have no idea how that happened. Had no issues with installation.

 

Would appreciate if you could post the folder contents. hopefully not too large. 

Share this post


Link to post
Share on other sites

Indeed, here are the files for the folder...

 

     ...\packages\hmap [autocreated base]

 

Extract to there and try to load the scenarios again, it should work after that.  The attachment here is 66.9Mb so I am not sure how long I can keep it around in the long term.

 

--------------------------

 

So, to figure out where the issue is, did you install the maps from the USB stick or from the download links?  One or the other might be missing this base map package. Or did you uncheck some of the maps in the install? (like the "hmap" base one)?  🤔

 

(If you unchecked some of the map packages to install, then there will certainly be errors like this)

 

Share this post


Link to post
Share on other sites

1. Download Link

2. Made sure all boxes were checked

 

I will re-download and confirm that i didn't miss anything else

 

Thanks for the files

Share this post


Link to post
Share on other sites

OK yes, please try again when you can.  Download links were tested, and that base map package seems to be present, but you never know what might have gone wrong.

 

If you try it again, move the contents of the  ...\maps\packages\hmap [autocreated base]  folder into a ZIP on your desktop temporarily, and then remove the files from the folder, and after install see if the files appear.  Thanks.

Share this post


Link to post
Share on other sites
2 hours ago, Apocalypse 31 said:

Ok, just reinstalled map pack from web site

Getting the same issue - missing hmap data.

Did you restart Steel Beasts after copying the map files?

If you had it running while doing so it wouldn't know that the content of the map packages folder changed (unless you pressed one of the refresh buttons that are sprinkled across the UI in various places).

Share this post


Link to post
Share on other sites

I think I am missing something. I keep seeing references to ' ...\maps\packages\ '; but I don't have a 'packages' directory.

 

My Maps directory's first map shows: eSim Games/Steel Beasts/Maps/(hgt)kookvalley2048[valley]v2 [autocreated base]. That's straight from the maps download and install. Did the install fail in some peculiar way, something else creates the packages directory or is this normal too?

 

Share this post


Link to post
Share on other sites

Thank you, any point in waiting for my package to arrive, with the stick to arrive?

 

And is it simple to change the location of the maps folder?

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, ssidiver said:

I think I am missing something. I keep seeing references to ' ...\maps\packages\ '; but I don't have a 'packages' directory.

 

My Maps directory's first map shows: eSim Games/Steel Beasts/Maps/(hgt)kookvalley2048[valley]v2 [autocreated base]. That's straight from the maps download and install. Did the install fail in some peculiar way, something else creates the packages directory or is this normal too?

 

If you can see reference to C:\ProgramData\eSim Games\Steel Beasts\maps\packages\ in the 'File paths', then  you can try to change it to  your custom directory.  Here is a video how to do this:

 

https://www.dropbox.com/s/87tq15xepr0g5hx/bandicam 2019-07-30 12-42-19-078.mp4?dl=0

 

...But before attempting to make changes please check if  your new  target directory contains 'Default' map package.  Also in order to make changes in  the 'File paths' menu you need to run SB as administrator.

 

Edited by Jartsev

Share this post


Link to post
Share on other sites

Interesting, thank you.

 

I'll continue with how I have it now waiting for the stick to arrive. Then I will re install the maps from that.

 

I have them on my D drive, I'm thinking there might be a noticeable difference in load times  from the C:. I do have enough space there, I just like data like things on the D drive.

 

I'll see after I've re-installed the maps.

 

Share this post


Link to post
Share on other sites

So back to the original issue...

 

The map in question (that I included here) is in the SB game installation.  So, what could have happened here is that when SB 4.1 was installed, perhaps the map path was changed to somewhere which differs from the path where the user told the map download installer to install the maps. In this case the error in the original report would occur.

 

We are looking to close this loophole by including the map mentioned here (hmap) in a patch, but otherwise if someone installs SB 4.1, then installs the map installer maps to the same path then all should be well.

Share this post


Link to post
Share on other sites

Yes, I found I had to manually create the 'packages' folder. Then point the maps installer to that directory and run it. And then reinstall Steel Beasts.

 

I found that if the maps installer is set to 'ProgramData/eSim Games/Steel Beasts' then the individual map folders ended up interleaved with the 'scenarios' and other folders, including the 'maps' folder.

 

For me the maps installer does not produce the folders that it does for others, no idea why!

 

Continuing to monitor how this installation holds up, so far so good!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...