Jump to content
Sign in to follow this  
Furia

Driver F9 with no control [RESOLVED]

Recommended Posts

I am not sure if this is a bug or a problem just in my side but I have tried with Pizarro and Marder in two different scenarios and everytime I jump into F9 Driver possition, the vehicle turns to the left at max speed and does not respond to any keyboard commands. I have tried all keyboard driving commands and all Joystick possitions and buttons but no impact

If you jump back again to the TC possition you can then direct the vehicle but everytime you jump into F9, it gest out of control.

 

Is this a known issue or do I have a control assignments trouble on my side?

Edited by Furia
Problem fixed

Share this post


Link to post
Share on other sites

This sounds like bug 7447, which however was verified as fixed in early July.

 

Procedure:

Quote

The 'Joystick axis configuration dialog' may now be used as soon as the program recognizes a connected joystick

 

Share this post


Link to post
Share on other sites

So you upgraded from 4.023, right? Or did you do a completely new installation? I take it you had your joystick connected&working with the previous version?

Share this post


Link to post
Share on other sites

I had a clean install.

I have never used the joytick to drive vehicles here. I do not have any joystick axis assigned to this fucntion.

I will check this out again this afternoon.

Share this post


Link to post
Share on other sites

Please, before you do anything in your options, could you upload your options and input options file? These can be found in '%APPDATA%\eSim Games\Steel Beasts\options', called 'std.hkf' and 'options.dat'?

Share this post


Link to post
Share on other sites

std.hkfoptions.dat

 

Here you have them.

I have just tested it in another scenario and different vehicle and I have made a video.

While in F9 the control indicator does not show any kind of imput to the left but the vehicle turns out of control. If I leave F9 possition, it stops.

While in F9 if I press left or right ke controls (A or D) there is no action and it does not show anz imput in the control icon on lower right.

I have never used the Joystick to drive in Steel Beasts in any previus version. Always keyboard.

 

 

Share this post


Link to post
Share on other sites
1 hour ago, Furia said:

I have never used the Joystick to drive in Steel Beasts in any previus version. Always keyboard.

...and yet, I saw in the video that when you pressed the "configure axes" button, some analog controller was connected.

If you're not using it, consider checking the option "Disable all joystick input". Will that change anything?

Share this post


Link to post
Share on other sites

I use the joystick to move the tower and the views but it is not assigned to any vehicle movement control.

I have tried the same F9 Driver with Joystick disabled and still happens the same same issue

Edited by Furia

Share this post


Link to post
Share on other sites

Disregard my last. Sorry my mistake. If I dissable Joystik imput the problem stops.

before I have by mistake just unselected automatic transmission instead Joystik.

 

So with Joystick enebled the problem persists. with Joystick dissabled problem appears

Edited by Furia

Share this post


Link to post
Share on other sites
32 minutes ago, Furia said:

If I dissable Joystik imput the problem stops.

 

with Joystick enebled the problem persists.

 

with Joystick dissabled problem appears

...uh...?

Share this post


Link to post
Share on other sites
1 hour ago, Ssnake said:

...uh...?

I meant this

 

 

As a curiosity, if I disembarck the vehicle when it is turning like mad and jump to another vehicle, the turning vehicle continues its turning loop and the IA does not stop it.

 

 

Share this post


Link to post
Share on other sites
53 minutes ago, Furia said:

I meant this

Okay, I think we have established by now that it is indeed a permanent joystick signal that's causing this.

Now, have you tried assigning the joystick direction signals to the different axes?

If there's one signal that is of no interest (e.g. a throttle lever) and if that one is assigned to control the X axis, then the resulting behavior would be, as seen, a vehicle violently turning left. So if you would then reassign that to the Z axis, and the regular joystick actions to X and Y, the resulting behavior might be a lot more sensible.

 

I'm not saying that "this is it", but in order to narrow it down this should be tried/confirmed that "it has been tried".

Share this post


Link to post
Share on other sites
37 minutes ago, Ssnake said:

Okay, I think we have established by now that it is indeed a permanent joystick signal that's causing this.

Now, have you tried assigning the joystick direction signals to the different axes?

If there's one signal that is of no interest (e.g. a throttle lever) and if that one is assigned to control the X axis, then the resulting behavior would be, as seen, a vehicle violently turning left. So if you would then reassign that to the Z axis, and the regular joystick actions to X and Y, the resulting behavior might be a lot more sensible.

 

I'm not saying that "this is it", but in order to narrow it down this should be tried/confirmed that "it has been tried".

Thanks for the support!!!

I fixed it re adjusting the "in game axis" assignments. Now I can drive the vehicle as well with the joystick although this was not my intent. In anz case it works now either with keyboard or joystick.

 

F9Driver.jpg.058831367632daebc8d348f0d63bbb13.jpg

 

If you look at the first video I posted on this thread, the intial assignment was X-R-R and that was causing the problem. With X-Y-Z now works great.

Thanks!

Edited by Furia

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...