Jump to content

Anti-Aliasing won't work (Radeon & Vista)


akm_ch
 Share

Recommended Posts

A couple of days I got my new PC. One of the first things I installed was of course SB Pro PE. The installation was hassle-free, afterwards SB was running fine ... with one (at least for me) totally annoying issue: anti-aliasing had no effect.

Whatever I configure in the Catalyst Control Center (level, filter), whatever resolution I select: no AA! It's driving me crazy.

Has anybody out there experienced the same problem, or even has a remedy? Any help appreciated!!!

My specs:

- Windows Vista SP 1 32bit

- Radeon 4870 with the latest Catalyst driver installed (8.11)

Incidentally, there were no AA-issues with my old PC and SB Pro PE (Windows XP, Radeon X800XT)

Catalyst.JPG.1ff50e5efb492a1bdbf890502a1

Catalyst.JPG.1ff50e5efb492a1bdbf890502a1

Link to comment
Share on other sites

  • Members

Don't use application-specific settings. AA must be set as a global setting.

I mean, it looks like you already have that judging from your dialog box, so I'm not sure if this is leading anywhere, but at least you should make sure that this is the way it is set up.

Link to comment
Share on other sites

Hi.. I also have an Ati 4870 videocard. Same "problems" with AA. Try to alt-tab few times and see what happens. Did not have any problems with other Ati cards.

Just tested: if you run SB in windows mode you can click Ati's CCC and change 8x AA to 4x AA and you have AA enabled. Then if you want you can run SB in full screen again. Strange thing is... if you change AA settings back to 8x AA your AA settings are lost and disabled in SB again. Must be Ati. Had this with older and newest drivers. Anyways.. you can get AA working with Ati 4870 card. I wonder if more have this problem with same videocard.

Link to comment
Share on other sites

Is there a difference between windowed and fullscreen mode?

I always play fullscreen. I only go to windows mode for changing AA settings to get it working with the Ati 4870. I had an Ati 2900XTX card and had no problems at all with AA settings, ever. This all changed when I upgraded to an Ati 4870.

Will test more tomorrow. Time for me to go to bed ;)

Link to comment
Share on other sites

Thanks Ssnake, thanks Wicked.

@Wicked: What you suggest sounds really, really encouraging. I will give your trick a try tomorrow (when I'm back at my game PC) and report to you afterwards

If this workaround should work for me too, I will be a happy SB user again.

Link to comment
Share on other sites

Well, I tried Wicked's procedure several times with different AA settings in the CCC ... unfortunately no effect: AA still turned off. It seems as if there is no way to turn AA on my video card. (The only thing that happend from time to time is a DirectX error box popping up, see attachment)

Ok, I give it up and get back to my flight simulators. (I know that I'm a purist ... but commanding a tank with all these edges along the surfaces is not only distracting me but also making me mad.)

error.JPG.63adda544e12301ac2cbd13274de5a

error.JPG.63adda544e12301ac2cbd13274de5a

Link to comment
Share on other sites

  • Members

Are you using the Bloom mod that was recently published here?

Would it work without it?

In one of the forum posts dealing with the same error message (different program, though) there was this remark:

I think you installed Zaro's Graphical Enhancement 2.5 With HDR. Well. I don't know why but hdr mod causes some kind of error while closing the M&B.
Link to comment
Share on other sites

I know this flies in the face of all advice to run your monitor and your sim at the same resolution.

But here's what worked for me after I bought a new screen and found the AA had lots of jagged lines in two sims (Falcon 4.0 being the other) with my Radeon 1950 Pro and AA and AF set at max:

I run the screen in its native, max resolution of 1680x1050x32.

I run the sims one notch lower: 1440x900x32.

Result: Very smooth lines and very good frame rates.

I'm no geek and I can't explain it but it worked for me.

If you try it and it isn't an improvement, you can always switch it back.

HT

Link to comment
Share on other sites

First of all let me say that the support in this forum is outstanding (both from esim games and the community). Kudos to you all.

@Ssnake: I have no whatsoever mod installed. I'm running SB out of the box, patched to "SB Pro PE 2.328 Hotfix".

You are also perfectly right with your statement that "there is no inherent reason why AA should not be possible." The most likely explanation for my issues might be a driver-related flaw?

Anyway, as requested by you, I attach a dxdiag log file. Maybe you find something extraordinary in it. Let's hope.

I should also mention that the DirectX error message, shown in the jpeg-file, obviously only appears when (1) SB is in windowed mode and (2) the AA setting is changed in the CCC application while the simulation is running. Given that, the error message isn't that surprising because normal users are not expected to do that.

@HotTom: I tried several resolutions, but it turned out for me that the resoultion had no impact on AA. What you describe might be caused by interpolation (applied by the monitor when the selected resoultion differs from the native resolution). But I'm not a geek either.

DxDiag.txt.d03a33fbdb03ed41c021812b5f787

DxDiag.txt

Link to comment
Share on other sites

Issue resolved!!

It follows an instructive account on what Vista and/or Vista drivers are worth:

After having had even more issues with other games and AA-settings I decided to repartition my hard drive and install Windows XP into the newly created partition. It followed a short struggle with the broken Vista boot loader, but even this issue could be fixed. So now I have a dual-boot system.

And just guest what happened to my AA issues after I had installed SB under Windows XP?You know the answer, ... they had gone. AA works again as in old days.

Bottom line: the use of Vista and/or Vista drivers is still strongly disencouraged from.

Link to comment
Share on other sites

  • Members

Well, it still is a problem for us in a way. I mean, what good does it to know that it's a Vista/driver problem. Sure, we could say that it is "their" fault, but that still doesn't solve the problem. :o

I mean, I'm glad that it works for you now, but what's with those who don't have or don't want a dual-boot setup (which, after all, requires two Windows licenses according to Microsoft's EULAs).

Link to comment
Share on other sites

To answer the still "unanswered question" (btw: also a fascinating piece of music by Charles Ives) how to have 2 Windows licenses at the same time, I will tell you the whole truth, though shocking it may be:

The XP license stems from my first (and now dismantled) gaming PC, dating back to 2002.

The Vista license came with a notebook I purchased a year ago. Just guess what happened to this Vista system? Once again the same answer: it was replaced by Ubuntu Linux after a few weeks of suffering from Vista performance and stability. I think this (although now completely off-topic) explains my special relationship with Vista ...

Link to comment
Share on other sites

  • 1 year later...

Hi :)

I unburied this topic because i suffer the same problem, meaning no Antialiasing under Windows 7 with an hd5770. I tried any ATI catalyst drivers since 8.9 to 10.2, i tried Ati Tray Tools , i switched the hd5770 with an old hd3870 card, nothing to do . :casstet:

I have to say i tried the hd5770 with WinXP on a friend's PC, everything runs smooth.

I'm lost :cry:

Any idea? :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...