Jump to content
Kelvinize

Does anyone run SB 4.160 + Map Pack on Win10 default Direct X 12 installation?

Recommended Posts

Hello Can lovers

 

I don't post this under support. It's not a SB PE PRO bug. It's the Kelvinize bug.

Background (else jump to "Long Short" below

Been issue solving my 7 FPS, "Not responding", Super freeze SB 4.160 PE Pro installation during 4 days getting mild headache.

My biggest bottleneck in hardware is my graphic card ZOTAC GeForce GTX 1080 AMP Extreme. The rest have better performance.

Therefore I doubt it's a hardware issue. Other app installed have been checked. Last is win10 pro itself to check.

 

7 FPS is with 1920X1080 resolution

Terrain setting and graphic settings all set to lowers possible.

Terrain from new map pack Fulda map (2015).

Location the smallest size possible with its lower right corner at the maps south west corner.

default theme.

Populates with one STRV122.

 

This is what I have found out.

Windows 10 64-bit run Direct X 12

 

Microsoft claim  Direct X 12 file d3d9.dll ( found in: C:\Windows\SysWOW64) to be the back compatible with any Direct X 9.0c application

My found version of d3d9.dll is 10.0.17763.1

 

Long Short

Can any helpful tank addict running default Win10, Direct X 12 and SB PE PRO 4.160 with at least 24 FPS check

what their d3d9.dll version is. File under C:\Windows\SysWOW64 and version found right click file -> properties -> tab "Details"

 

It would be very helpful and appreciated

Thank you

image.png

Edited by Kelvinize

Share this post


Link to post
Share on other sites

My Version is 10.0.18362.267 and the game runs very smooth on my machine with 1920x1080 and all settings pretty much set to max.

 

Windows Version is Win 10 Pro 64-Bit Version 1903 build 18362.295. Graphics card is a GeForce RTX 2080 Ti.

Edited by raskil

Share this post


Link to post
Share on other sites
26 minutes ago, raskil said:

My Version is 10.0.18362.267 and the game runs very smooth on my machine with 1920x1080 and all settings pretty much set to...

...default. Same d3dx9.dll version as above, using a notebook with a GTX 1070M in it.

Share this post


Link to post
Share on other sites
7 hours ago, raskil said:

My Version is 10.0.18362.267 and the game runs very smooth on my machine with 1920x1080

 

Same here!

 

Share this post


Link to post
Share on other sites
16 hours ago, Kelvinize said:

Other app installed have been checked

I still feel compelled to ask- what security software are you using?

Share this post


Link to post
Share on other sites
On 9/2/2019 at 9:21 PM, Ssnake said:

...default. Same d3dx9.dll version as above, using a notebook with a GTX 1070M in it.

Hello Ssnake

 

For me it was the Direct X D3D9.dll file that was the reason to my setup's low performance.

I found on the net one D3D9.dll close to the version you guys run.

With absolute everything set at max plus now running in 2560x2440 I have in F8 view minimum 30 fps up to 45 fps

In F6 gunner view I got minimum 62 fps up to 68 fps.

Now I wonder if your versions are even better for me.... Hmmmm..... Nope that for another day.

I have a new version of Steelbeast PE PRO to bend to my will.

 

I am happy now. You have cultivated a fantastic forum together with all its members.

One posting and my problems are solved. This was a user problem hosted in my setup.

 

 

Hallelujah my SABOT is loaded

 

Edited by Kelvinize

Share this post


Link to post
Share on other sites
On 9/2/2019 at 8:53 PM, raskil said:

My Version is 10.0.18362.267 and the game runs very smooth on my machine with 1920x1080 and all settings pretty much set to max.

 

Windows Version is Win 10 Pro 64-Bit Version 1903 build 18362.295. Graphics card is a GeForce RTX 2080 Ti.

 raskil! You are my savior. Now my SB run like a ferret on amphetamine. worst FPS with everything on max is 30 fps

I got nearly the same dll you have from the net.

 

Booom need to go play now 🙂

Edited by Kelvinize

Share this post


Link to post
Share on other sites
On 9/3/2019 at 4:24 AM, ssidiver said:

Same here!

 

Its great people care. With you and Ssnake confirming the version of dll raskil gave me I was fure what to get. You could have let it be but you posted and it made it easier for me. Thank you ssidver

Share this post


Link to post
Share on other sites
On 9/3/2019 at 8:20 AM, Bond_Villian said:

I still feel compelled to ask- what security software are you using?

Oh please Bond_Villian feel compelled - 😁 I run Window defender default with Win10 and enforce it with "Malwarebytes". I have had them off under my trial and error period. I now have them on excluding the Steelbeast folders in their settings instead. I see no impact in the operation of the Steelbeast PE PRO with them off, on or with files excluded.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...