Jump to content
Sign in to follow this  
Colebrook

Tanks shooting at nothing

Recommended Posts

And they keep shooting and shooting although there is nothing in sight.

I upload a test scenario:

Blue tanks have red tanks to the south.

Blue tanks have 2 positions, a covered position and a firing position(more to the south).

Move the blue tanks (using the proceed order) to the firing position, when they spot the red tanks wait a bit until they exchange some shots.

Retreat the blue tanks to the covered position( using the proceed order)

The red tanks will keep firing even though they have nothing in sight.

Firing bug.sce

Share this post


Link to post
Share on other sites

Thanks this one is  easily  reproducible with provided  scenario, but issue seems to belong to known bug:

 

Fixing of this bug is not very easy or fast :(

 

Edit:

May be a new bug in fact... Looks like something else may be involved...

Share this post


Link to post
Share on other sites
23 minutes ago, Jartsev said:

Fixing of this bug is not very easy or fast :(

You enjoy my full trust in fixing the 🐛

☺️

Share this post


Link to post
Share on other sites

Yes i think they are different, in  the first bug report the tank detects the enemy(because is visible), but hits the ground because gunner ia ignores that gps is higher than the gun.

In the second one the tanks are totally out of sight, however ai spots them ans starts firing.

Edited by Colebrook

Share this post


Link to post
Share on other sites

Thanks for that report.

 

The AI has always been aware of a target that is concealed, to keep the AI from going completely unaware of it - it basically gives the AI short term memory. This is similar to how a human would watch a hill once a target has appeared there, to observe on whether it presents itself again.

 

The bug though is that instead of just watching (for a short time) the area where the target  previously appeared, the AI continues to fire at the area too. We will of course fix that.

Share this post


Link to post
Share on other sites

Actually, it seems to be very specific to the situation in that test scenario (it doesn't happen all the time). 

 

This could be a bug that was always there (not new to 4.1), but that it only happens in very specific situations.  We will investigate.

Share this post


Link to post
Share on other sites

Guys, I have one related to this. I have a scenario where I am ambushing BMP-1s, MTLBs and BTRs coming around a hill from the side with a 0.50" HMG team. What happens is the vehicles advance toward the HMG team to a point where they are still entirely screened by intervening "bumpy" terrain and both they and the HMG team just keep shooting into the intervening ground. This goes on until I bring another asset over the ridge opposite and shoot the offending vehicle from behind. Thinking about it, I have had this happen elsewhere in the same scenario, also with a ZSU-23-4, which makes for quite spectacular fireworks.

Edited by ChrisWerb

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...