Jump to content
Sign in to follow this  
BigBadVuk

Dynamic lead in Leo 2Ax refuses to work

Recommended Posts

Upgraded today to latest version, it seems for some reason my dynamic lead button on joystick is now shutting down the turret making it immobile instead to apply the lead.

Other already assigned controls from same joystick work ( thermal, lasing, B/W hot etc.) but not the dynamic lead. Even reverting to defaults for all assigned controls and assigning just same button for dynamic lead had same issues.

 

Any ideas? Bug or some systems have changed so i need to go through all tutorials ( but i tried tutorial for Leo2 gunner and it is same behavior there, and it works with pressing P key, but it doesnt work with pressing my joystick key, which is insane since they are assigned to the same function?

 

Share this post


Link to post
Share on other sites

Cannot confirm this. Just tried the Leopard 2A5 on the gunnery range and the dynamic lead work as designated. I'm using the default control settings with Thrustmaster T 16000M.

Share this post


Link to post
Share on other sites

Well if it wasnt for the other games or vehicles i would say that joystick or its software went crazy - but DCS works fine, Elite is fine, FSX and Xplane are fine... only SB is acting up.

 

Share this post


Link to post
Share on other sites

Just provide some more informations. Which version of SB are you running (4.161 is the actual one) which joystick are you using? Do you have/use some kind of config software for your joystick? Are you sure, you press (and hold) Joystick Button 3 (which is the deafult setting for the dynamic lead on the Leopard 2)?

Share this post


Link to post
Share on other sites

It may possibly be a keypress assignment  "conflict" as there is now two or more items sharing the "lead" or palm switch.

 

 

Share this post


Link to post
Share on other sites
17 minutes ago, ht-57 said:

It may possibly be a keypress assignment  "conflict" as there is now two or more items sharing the "lead" or palm switch.

 

 

This is #1 on my list of suspicious things... But i never changed any input in between 4.013 and latest 4.161.  (if my memory serves me)

I use latest SB pro, clean installation and i use X55 Saitek HOTAS without throttle quadrant in this case, and in combination with Track IR and Voice Attack. Everything else i have trie din past few hours worked, issue is with this input from joystick, and even that is weird because pressing P key does the trick, but not pressing the joystick button itself despite it working 24h ago.

 

Reverting everything to default, didnt helped, that same button again assigned to Dynamic Lead for Gunner in Leo 2 stops the turred dead in its track, like i tried to hold same button in Abrams. Effect is identical - no traverse or elevation. 

Im confused as hell...

Share this post


Link to post
Share on other sites

If you have not done this, open the keybinding editor and look thoroughly thru entire list to see what else is sharing that binding and /change or delete it.

I had an issue with a couple of bindings when I up'ed to 4.1 as well.  One item for myself that I had to ask forum members for help with was the tis focus in the m1a1, as its naming in the binding editor isn't what I thought It would be .

Share this post


Link to post
Share on other sites

Default assignments  for  dynamic lead in 4.161 : 'P'  key of the  keyboard, middle button of the mouse  and joystick button #3,  while default assignment for the palm switch for Leo-2's gunner is  joystick  button #5. Please  check  controls list for possible conflicts.

Share this post


Link to post
Share on other sites

Thank you ill have to go tomorrow through the whole list, somehow i think there is a conflict in default settings for LEo and Abrams families. For first it is dynamic lead, for second it is palm switch disengage.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...