Jump to content
Wax Savage

MAP UID not recognized by server [RESOLVED]

Recommended Posts

  • Hello,

     

    On the main forum screen I noted that today there is a new downloadable scenario.

    I downloaded the updated scenario "Heavy CT Delay v Tank Battalion FD v2.3 (4.161).rar"

     

    The map UID cannot be found located on the server by my copy of SB 4.161

     

    UID #  d87bfd19-f78d-4153-ab4c-d7c9935c454b

     

    any thoughts?

Share this post


Link to post
Share on other sites
14 minutes ago, Wax Savage said:
  • Hello,

     

    On the main forum screen I noted that today there is a new downloadable scenario.

    I downloaded the updated scenario "Heavy CT Delay v Tank Battalion FD v2.3 (4.161).rar"

     

    The map UID cannot be found located on the server by my copy of SB 4.161

     

    UID #  d87bfd19-f78d-4153-ab4c-d7c9935c454b

     

    any thoughts?

Probably   downloaded  scenario is based on custom map package(base or delta), while at this moment map server only contains  packages delivered  with 4.1 update(e.g.  very same maps as installed with Maps Installer). So you have  two options:

-replace  the scenario map with  more-or-less similar one

-to ask  maker of scenario to provide proper map package

Share this post


Link to post
Share on other sites

Hi,

Ive already contacted the author of the scenario, and asked him to post the map.  Stay tuned!

Share this post


Link to post
Share on other sites

Yes, apologies, this was an oversight of the new 4.1x scenario requirements on my part and the need to upload an unpublished underlying map separately (it’s hard teaching an old dog new tricks!). I’m intending to upload the relevant map tomorrow evening my time so hopefully it’s available to associate with the scenario by mid-week latest and you can enjoy it after that.

 

Cheers

Share this post


Link to post
Share on other sites

I have downloaded the latest version of the file and I still cannot get the Map Package Installer to recognise the UID. 

Share this post


Link to post
Share on other sites

What do you mean "not recognize the UID"?

 

That it doesn't show up in the list of available maps?

If it is a delta map, it's probably in the wrong folder. You may think that it is in the correct location, but it isn't.

 

Also, why do you write that you expect the map package installer to "recognize" the map UID?

Once that the map packages have been installed, the installer should never be needed again.

Share this post


Link to post
Share on other sites

There’s another report of this in another thread: 

I’m trying to troubleshoot the issue for users and have a theory. On the relevant page of the Downloads section where you upload ‘Map Packages 4.1+’ it says: “If it is a delta map, then Zip/RAR the appropriate delta map folder inside the base map's "deltas" folder. If it is a new base map (ie. if its a completely new height map), then Zip/RAR the base map folder.”, per: https://www.steelbeasts.com/files/category/137-map-packages-41/

 

The map used for this scenario is a Delta map so I followed the Delta map process but, if the user doesn’t have the Base map installed, will the Delta map process still work when trying to play the scenario? Obviously I have both Base and Delta installed, otherwise the scenario wouldn’t work for me, but the map is not a default map offered with Steel Beasts so most other users won’t (other than some potentially in BG ANZAC). Perhaps I misunderstood the instructions and need to upload Base and Delta in some combination?

 

Cheers      

 

 

Share this post


Link to post
Share on other sites

Yes,  delta map   only hold changes relative to the base map, and you cannot use deltas without base maps. So  if you are going to distribute custom delta made  on custom base, you need to provide them both, or map downloader will not be able to download anything.

Share this post


Link to post
Share on other sites
2 hours ago, Panzer_Leader said:

The map used for this scenario is a Delta map so I followed the Delta map process but, if the user doesn’t have the Base map installed, will the Delta map process still work when trying to play the scenario? Obviously I have both Base and Delta installed, otherwise the scenario wouldn’t work for me, but the map is not a default map offered with Steel Beasts so most other users won’t (other than some potentially in BG ANZAC). Perhaps I misunderstood the instructions and need to upload Base and Delta in some combination?

 

Cheers      

 

 

Panzer_Leader,

 

Yes you'll need to upload the whole package since its not a part of the default installation.

 

Certainly I haven't given it to eSim to be added to the installation bundle.

 

Edited by Gibsonm

Share this post


Link to post
Share on other sites
2 hours ago, Jartsev said:

Yes,  delta map   only hold changes relative to the base map, and you cannot use deltas without base maps. So  if you are going to distribute custom delta made  on custom base, you need to provide them both, or map downloader will not be able to download anything.

Thanks @Jartsev, to confirm, and ensure I get the upload correct this time, do I include the Base map and Delta map as a single upload (e.g. Base map folder > Delta map folder) or two separate uploads: Base map file plus Delta map file (already uploaded)?

 

Apologies if this should be clearer to me but I'm definitely muddling my way through this one...

Share this post


Link to post
Share on other sites

Separate uploads won't hurt. A complete upload is probably also okay; at this point all uploads are added manually to the eSim map server (and we may keep this habit, even once the upload software of the SB Map Tools has been completed, simply because it's out official site and we want to curate its content.

Share this post


Link to post
Share on other sites
15 hours ago, Ssnake said:

What do you mean "not recognize the UID"?

 

That it doesn't show up in the list of available maps?

If it is a delta map, it's probably in the wrong folder. You may think that it is in the correct location, but it isn't.

 

Also, why do you write that you expect the map package installer to "recognize" the map UID?

Once that the map packages have been installed, the installer should never be needed again.

Thank you for your very polite and comprehensive reply. I only came here looking for some assistance.

 

12 hours ago, Panzer_Leader said:

There’s another report of this in another thread: 

I’m trying to troubleshoot the issue for users and have a theory. On the relevant page of the Downloads section where you upload ‘Map Packages 4.1+’ it says: “If it is a delta map, then Zip/RAR the appropriate delta map folder inside the base map's "deltas" folder. If it is a new base map (ie. if its a completely new height map), then Zip/RAR the base map folder.”, per: https://www.steelbeasts.com/files/category/137-map-packages-41/

 

The map used for this scenario is a Delta map so I followed the Delta map process but, if the user doesn’t have the Base map installed, will the Delta map process still work when trying to play the scenario? Obviously I have both Base and Delta installed, otherwise the scenario wouldn’t work for me, but the map is not a default map offered with Steel Beasts so most other users won’t (other than some potentially in BG ANZAC). Perhaps I misunderstood the instructions and need to upload Base and Delta in some combination?

 

Cheers      

 

 

Panzer Leader, thank you very much for taking the time and trouble to look into this issue.

 

Best regards

Steve

Share this post


Link to post
Share on other sites
8 hours ago, Ssnake said:

Separate uploads won't hurt.

Thanks @Ssnake.  I have separately uploaded the Base map 'OTW AI [autocreated base]' as suggested: 

The previously uploaded Delta map 'OTW Beaudesert ver 3' (UID d87bfd19-f78d-4153-ab4c-d7c9935c454b) needs to be installed as the /deltas folder to this Base map for the scenario 'Heavy CT Delay v Tank Battalion FD' to work correctly (as I currently understand it).

 

I will continue to troubleshoot if this still does not work as hoped. 

Share this post


Link to post
Share on other sites
Posted (edited)

Hi Panzer Leader.

I have deleted all the files related to this scenario and redownloaded it all including the Base map 'OTW AI [autocreated base] and followed your installation instructions to the letter.

However when I enter the UID d87bfd19-f78d-4153-ab4c-d7c9935c454b into the Map Package Downloader nothing happens.

If I go to the downloader in the game and enter the UID and press "Download Package" again nothing happens, If I press "Query Package" the search bar comes up and would probably run indefinitely looking for it.

The file structure I have is " This PC / OSC / Program Data / E-SIMGames / Steel Beasts / Maps / Packages / OTW AI [Autocreated Base]" , for the new base map and " This PC / OSC / Program Data / E-SIMGames / Steel Beasts / Scenarios / Single" for the Heavy CT Delay..... files.

Hope this is of some help.

Steve

PS I have just checked the "Maps / Height" folder and there are two files "OTW AI .hgt" and "OTW AO .hgt "

 

Edited by Brakefan
Added PS

Share this post


Link to post
Share on other sites
37 minutes ago, Brakefan said:

Hi Panzer Leader.

I have deleted all the files related to this scenario and redownloaded it all including the Base map 'OTW AI [autocreated base] and followed your installation instructions to the letter.

However when I enter the UID d87bfd19-f78d-4153-ab4c-d7c9935c454b into the Map Package Downloader nothing happens.

If I go to the downloader in the game and enter the UID and press "Download Package" again nothing happens, If I press "Query Package" the search bar comes up and would probably run indefinitely looking for it.

The file structure I have is " This PC / OSC / Program Data / E-SIMGames / Steel Beasts / Maps / Packages / OTW AI [Autocreated Base]" , for the new base map and " This PC / OSC / Program Data / E-SIMGames / Steel Beasts / Scenarios / Single" for the Heavy CT Delay..... files.

Hope this is of some help.

Steve

PS I have just checked the "Maps / Height" folder and there are two files "OTW AI .hgt" and "OTW AO .hgt "

 

Same here.

Share this post


Link to post
Share on other sites

Well,  I just checked(literally a couple of minutes ago)- both in-game downloader and  map download manager are  able to  download  base and delta packages of Beaudesert map. So it seems  that base  package  was  finally  uploaded to the server.

 

Could you try  download this map again, and see what happens?

 

 

 

 

Share this post


Link to post
Share on other sites
46 minutes ago, Jartsev said:

Well,  I just checked(literally a couple of minutes ago)- both in-game downloader and  map download manager are  able to  download  base and delta packages of Beaudesert map. So it seems  that base  package  was  finally  uploaded to the server.

Yes, @Sean confirmed earlier today via PM that both Base and Delta maps should now auto-download from the server when the scenario is loaded. That's the theory. I'm not sure if earlier or incorrect download attempts have the ability to corrupt that process?

Share this post


Link to post
Share on other sites
12 minutes ago, Panzer_Leader said:

Yes, @Sean confirmed earlier today via PM that both Base and Delta maps should now auto-download from the server when the scenario is loaded. That's the theory. I'm not sure if earlier or incorrect download attempts have the ability to corrupt that process?

In theory they should't.  Probably one thing worth to do is  to click  blue  "Refresh map package folder" button  before trying  to  query or download package with  Map Download Manager.

Share this post


Link to post
Share on other sites

Success, Thanks guys.

I tried the "Refresh Map Package Folder" but that didn't work.

In frustration I shut down and restarted my PC and tried the download manager again and ……. It worked!

 

Thanks for your perseverance.

Steve

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, Brakefan said:

Success, Thanks guys.

I tried the "Refresh Map Package Folder" but that didn't work.

In frustration I shut down and restarted my PC and tried the download manager again and ……. It worked!

 

Thanks for your perseverance.

Steve

Great result! It took input from a number of people to troubleshoot and resolve (thanks!) but we got there in the end. Hopefully @stormrider_sp, and anyone else affected, has similar success.

 

Cheers

Edited by Panzer_Leader

Share this post


Link to post
Share on other sites

I got it to work, looks like nice work.

 

Even though the download manager still will not run for me. I get 'Unable to execute more than one instance simultaneously' even after I have stopped Steel Beasts Map Package Download Service, and yes that starts when the PC starts. And there is no little icon in the windows tray.

 

It is not an issue for me yet.

Share this post


Link to post
Share on other sites
52 minutes ago, ssidiver said:

Even though the download manager still will not run for me. I get 'Unable to execute more than one instance simultaneously' even after I have stopped Steel Beasts Map Package Download Service, and yes that starts when the PC starts. And there is no little icon in the windows tray.

Plese try  to delete C:\ProgramData\eSim Games\Steel Beasts Map Tools\IPC\PackageDownloadManagerMutex file, this may help.

Share this post


Link to post
Share on other sites

Also, use the red “x” button that looks like a stop sign rather than the “x” in the upper right corner of the window.  Doing this will keep you from getting that error message.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...