Jump to content
Bond_Villian

PC locking up in map & scenario editors [RESOLVED]

Recommended Posts

58 minutes ago, Bond_Villian said:

Been getting many lockups while using the editors, various circumstances.

My question is; does this log indicate a corrupted map?

Cheers

DebugLog_2.txt 545.38 kB · 2 downloads

Well, I passed  the information to programmers, but  at first glance  this  looks like your computer doesn't have  sufficient RAM. So  question is,  if  this  issue is specific to any particular map or not, and if it is map-specific, then what is the map,  its state(published  or  unpublished),  if there were made any changes to the heights etc...

Share this post


Link to post
Share on other sites

Well ive been getting PC locking up during the 'Action phase' in the editor (testing scenarios) on several maps (both published and delta state) , and in the map editor while saving and creating new delta maps and applying road leveling changes. Most frequent crashes have been occurring recently on an edited version of the bekibekibekistan_forrested map, with levelled roads and buildings (22+GB delta).

Heres some system info;

 

Radeon Software Version - 19.9.2
Radeon Software Edition - Adrenalin 2019
Graphics Chipset - Radeon RX 580 Series
Memory Size - 8192 MB
Memory Type - GDDR5
Core Clock - 1366 MHz
Windows Version - Windows 7 (Service Pack 1) (64 bit)
System Memory - 12 GB
CPU Type - Intel(R) Core(TM) i7 CPU 920 @ 2.67GHz

 

Edited by Bond_Villian

Share this post


Link to post
Share on other sites

Thanks.  Definitely this is problem of RAM amount vs. extensive size of map package. We are working on  this, but I cannot promise  quick fix

Share this post


Link to post
Share on other sites
3 minutes ago, Jartsev said:

Thanks.  Definitely it is problem of RAM amount...

Thankyou for the quick reply, do you think this is also related to memory?

[13:28:20,595] CGame ERROR: TiledBitmap::get_pixel, failed to obtain valid height data!

Also, my concern is that ive been getting these lockups while testing the scenario in the editor with published maps (smaller file size)...

Edited by Bond_Villian

Share this post


Link to post
Share on other sites
1 minute ago, Bond_Villian said:

Thankyou for the quick reply, do you think this is also related to memory?

[13:28:20,595] CGame ERROR: TiledBitmap::get_pixel, failed to obtain valid height data!

Well, everything starts here:

[12:49:26,082] CGame WARN : TiledBitmap::get_block, error allocating memory. Will re-attempt after processing the cache.

 

...and  basically all  subsequent entries are depicting  the consequences...

Share this post


Link to post
Share on other sites
9 minutes ago, Jartsev said:

this is problem of RAM amount vs. extensive size of map package

So the map package size is too large even in its 'published' state (about 86MB) or in its 'delta' state (22+ GB) ?

Cheers

Share this post


Link to post
Share on other sites
1 minute ago, Bond_Villian said:

So the map package size is too large even in its 'published' state (about 86MB) or in its 'delta' state (22+ GB) ?

Cheers

You need  to publish the delta- this  will apply some compression and reduce its size.

Share this post


Link to post
Share on other sites
4 minutes ago, Bond_Villian said:

I have had crashes while testing the scenario in the editor using the published delta version of the map, its about 86 MB

Ouch... This is something else...

Share this post


Link to post
Share on other sites

So... It appears, that issue is indeed caused by  amount of RAM available. You can try to address this by  decreasing 'Dynamic cache size' from 100 to 50. This may not necessary help in 100% of all possible situations,  but still may provide some improvement.

Share this post


Link to post
Share on other sites
25 minutes ago, Jartsev said:

So... It appears, that issue is indeed caused by  amount of RAM available. You can try to address this by  decreasing 'Dynamic cache size' from 100 to 50. This may not necessary help in 100% of all possible situations,  but still may provide some improvement.

Ok, thanks

Share this post


Link to post
Share on other sites

 

I have found that running the mission editor sbpro uses- 9-10g of ram. when using the map editor I average 26g of ram but if I do a bit of terrain editing

I have run up to 45g of ram use .

So @ the end of the day you need to add a couple sticks of ram- 16g will not be adequate to utilize the map editor for terrain editing as I was having similar issues

with 16g.

 That said if you are going to edit terrain on one map you are going to use 60+g of hd space. If sbpro main directory resides in the same folder you have

used 80+g of hd. So again you could also be running yourself out of hd space if you are not vigilant in knowing how much is on said hd's as that will also

crash and hang sbpro

 

Share this post


Link to post
Share on other sites

Thanks for the info ht-57, i do plan to get a new PC fairly soon. My HDD has over 200GB of free space, so thats not likely the issue.

I suspect my problems are a lack of RAM and shitty drivers for the GPU (still trying to find a stable driver for the RX 580).

Edited by Bond_Villian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...