Jump to content

Is this a 4.162 Map Editor 'BUG' ??


Recommended Posts

Using the Map Editor in SB version 4.161, I’ve been creating a detailed map for the past 3 months.

After installing SB version 4.162 and opening its Map Editor, I continued working on my map project and discovered that the “flatten under selected objects” function does not place the structures at the correct above ground level (as it did in Ver. 4.161).  The foundations remain buried too deep and the floors covered over by dirt/grass etc.

 Also, a very large percentage of buildings that were properly placed over the past 3 months (with version 4.161) are now showing grass in on the floor of the structure instead of the wood floors etc.    It appears that buildings have sunk into the ground in version 4.162.

Building #25 seems particularly affected.

Link to post
Share on other sites

Rendering of terrain in the map editor and in the mission editor(also during gameplay session) is indeed different due to certain technical reasons. And, speaking of  buildings sinking in to the ground, as far as I can see at this point,  this issue was addressed.

Link to post
Share on other sites
6 hours ago, Jartsev said:

Rendering of terrain in the map editor and in the mission editor(also during gameplay session) is indeed different due to certain technical reasons. And, speaking of  buildings sinking in to the ground, as far as I can see at this point,  this issue was addressed.

Hi Bond_Villian and Jarvs,

Mission editor is not at issue here. The sunken building problem is manifesting itself in the 4.162 Map Editor. The "flatten under selected objects” function works great in 4.161. It is failing (for me) in over 50% ~ 90% of the instances on 4.162. Plus it seems that buildings that were properly flattened in 4.161 are displaying as below grade in 4.162.

 

To ensure 4.162 was properly installed I have deleted and re-installed 4.162 three times (I have 4.161 on a separate hard-drive for doing a/b comparisons) . As of now, I have decided to continue performing all map edits on 4.161.   

 

Edited by Wax Savage
Link to post
Share on other sites
15 hours ago, Wax Savage said:

Mission editor is not at issue here. The sunken building problem is manifesting itself in the 4.162 Map Editor

@Wax Savage

My point was that it may look wrong in the map editor, but when you actually use the map to make a scenario on (in the scenario editor) it may look fine. Hence, its worth checking the map/s in question in the scenario editor to see if the issues carry over to where it counts. Worth a look :)

Edited by Bond_Villian
Link to post
Share on other sites

There is at least one known bug in the Map Editor that "mangles" procedurally edited terrain  in the preview, but when looking at the map in a mission, the seemingly mangled parts are actually fine. Your observations may be a manifestation of that same bug.  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...