Jump to content
BadgerDog

File path edit for SB3?

Recommended Posts

I wanted to test in SB3 the same tutorial I was having FPS issues with.

 

So, I loaded up my installed SB3 and got the error message below when I select any scenario.

 

 I checked the SB3 install and the tutorial files are all there, but I guess SB3 path can't find them.

 

Where do I edit the SB3 file to add the path and also, where the heck is the LOG file referred to?  I can't find it anywhere.  😏

 

Thanks....

 

Regards,

Doug

IMG_0991.JPG

Share this post


Link to post
Share on other sites

You may recall I said you could have both SB3.x and SB4.x on you machine but you may run into "some issues".

 

Pretty sure this is one of the issues.

 

On my machine (Win 10) the Tutorial (as opposed to player created) scenarios are here:

 

C:\ProgramData\eSim Games\Steel Beasts\scenarios.

 

There is only one set.

 

These will have been created in SB 4.x (to use the new maps, show off new artwork, etc.), esp if you installed SB 3.x first and then SB 4.x.

 

SB lacks backward compatibility to ensure that features used in a scenario created in 4.x doesn't create an error if opened in 3.x (for example if you used a vehicle that exists in SB 4.x but didn't exist in SB 3.x).

 

You are effectively trying to open a 4.x scenario in 3.x

 

This extends to within the 4.x family - e.g. a scenario created in 4.167 can't be opened in say 4.161. A 4.161 scenario can however be opened in 4.167.

 

I no longer have SB Pro PE 3.x on this machine but attempting to open the M1A1 TC Tutorial C file using an older version of the classroom version (3.333) gave me the same dialogue box above and the log displays this:

 

[07:56:47,909] WARN : -------------------------------
[07:56:47,909] WARN : Steel Beasts Log File v3.333 ANZAC (x64)
[07:56:47,910] WARN : Sat Aug 01 07:56:47 202 / 36956
[07:56:47,910] WARN : -------------------------------
[07:56:47,910] WARN : +--+ MEMORY USAGE INFO (SteelBeasts START):
[07:56:47,910] WARN : |  | Process: 4.2 GB (0 % of 128.0 TB total, 128.0 TB free) 4.2 GB min/4.2 GB max
[07:56:47,910] WARN : |  | Physical: 13.6 GB (28 % of 48.0 GB total, 34.3 GB free) 13.6 GB min/13.6 GB max
[07:56:47,910] WARN : +--+ Pagefile: 17.3 GB (32 % of 55.0 GB total, 37.6 GB free) 17.3 GB min/17.3 GB max
[07:57:12,262] ERROR: Incompatible scenario! Feature 118 is missing!
[07:57:12,262] ERROR: *** Failed Reading Tag: 48
[07:57:14,659] ERROR: Incompatible scenario! Feature 118 is missing!
[07:57:14,659] ERROR: *** Failed Reading Tag: 48
[07:57:15,443] ERROR: Incompatible scenario! Feature 118 is missing!
[07:57:15,443] ERROR: *** Failed Reading Tag: 48
[07:57:17,213] ERROR: Incompatible scenario! Feature 118 is missing!
[07:57:17,213] ERROR: *** Failed Reading Tag: 48
[07:57:20,081] WARN : +--+ MEMORY USAGE INFO (LoadFileToPlay start):
[07:57:20,081] WARN : |  | Process: 4.9 GB (0 % of 128.0 TB total, 128.0 TB free) 4.2 GB min/4.9 GB max
[07:57:20,081] WARN : |  | Physical: 14.1 GB (29 % of 48.0 GB total, 33.8 GB free) 13.6 GB min/14.1 GB max
[07:57:20,081] WARN : +--+ Pagefile: 17.9 GB (33 % of 55.0 GB total, 37.0 GB free) 17.3 GB min/17.9 GB max
[07:57:22,536] ERROR: Incompatible scenario! Feature 118 is missing!
[07:57:22,536] ERROR: *** Failed Reading Tag: 48
[07:57:22,537] ERROR: Error reading scenario file!
[07:57:22,537] ERROR: CGame::ReadScenarioFromFile failed
[07:57:22,537] ERROR: Error setting up new game!
[07:57:28,636] WARN : +--+ MEMORY USAGE INFO (SteelBeasts END):
[07:57:28,636] WARN : |  | Process: 4.8 GB (0 % of 128.0 TB total, 128.0 TB free) 4.2 GB min/4.9 GB max
[07:57:28,636] WARN : |  | Physical: 14.0 GB (29 % of 48.0 GB total, 33.9 GB free) 13.6 GB min/14.1 GB max
[07:57:28,636] WARN : +--+ Pagefile: 17.8 GB (32 % of 55.0 GB total, 37.2 GB free) 17.3 GB min/17.9 GB max
[07:57:31,544] WARN : Done

 

As for the "Log", try looking for the "DebugLog.txt" here: C:\Users\mark\Documents\eSim Games\Steel Beasts\logs

 

Your path will vary depending of where you installed it, your user account etc.

 

A new DebugLog.txt file is written every time so the one you are looking for maybe "DebugLog_X.txt" where X = the number of times you've started SB since the issue.

 

DebugLog.txt

Edited by Gibsonm

Share this post


Link to post
Share on other sites

So....for clarity ... because I installed SB3 first, would this be the simplest way to fix this?

 

If I completely uninstall SB3 using its own uninstaller, then re-install the entire SB3 again, that should ensure that all the scenarios and tutorials so are now correctly just for SB3?

 

Thanks for the feedback partner.... 😉

Share this post


Link to post
Share on other sites

No.

 

You'd need to:

 

1. Uninstall 4.x (removing the current maps and Tutorial files).

 

2. Install SB 3.x (installing the Tutorial files that run in 3.x)

 

3. Run your test - for the issue in the other thread.

 

4. Install SB 4.x again

 

If you are going to regularly / frequently alternate then you'd probably need to do something like:

 

1. Uninstall 4.x (removing the current maps and Tutorial files).

 

2. Install SB 3.x (installing the Tutorial files that run in 3.x)

 

3. Open your equivalent of C:\ProgramData\eSim Games\Steel Beasts\scenarios\z_Reseved\tut

 

4. Rename all the files in all the sub folders from say C:\ProgramData\eSim Games\Steel Beasts\scenarios\z_Reseved\tut\M1A1\18 M1 TC C.sce to something like "18 M1 TC C_3028.sce" so you have the 3.028 version.

 

5. You'd also have to rename the files in

 

C:\ProgramData\eSim Games\Steel Beasts\scenarios\z_Reseved\InstAct and

 

C:\ProgramData\eSim Games\Steel Beasts\scenarios\z_Reseved\Range

 

too so that the Range scenarios and Instant Action scenarios worked too

 

6. Install 4.167

 

Then you'd have:

 

C:\ProgramData\eSim Games\Steel Beasts\scenarios\z_Reseved\tut\M1A1\18 M1 TC C.sce (the current, 4.167 version) and

 

C:\ProgramData\eSim Games\Steel Beasts\scenarios\z_Reseved\tut\M1A1\18 M1 TC C_3028.sce (the 3.028 version)

 

Then when running the Tutorial / Range or Instant Action load the file that matches the version you are running.

 

As you can see though being able to run both versions of everything concurrently rapidly spirals.

 

I'd suggest you just do the testing of the "like for like" scenario in 3 vs 4 (i.e. rename one or two tutorial scenarios only) and then settle on 4, assuming the performance is OK.

 

I'm pretty sure the default install scenarios (the ones in "Scenarios" as opposed to "My Scenarios") will work in both 3.x and 4.x so your other licenses should be OK for those.

 

Share this post


Link to post
Share on other sites

😲 wow ...

 

Thanks for the detailed instructions.

 

I didn't expect it to become a religious experience to do this. 🤣

 

Maybe I'll just skip the 5 licenses I have in SB3, delete SB3 completely and move onto SB4.

 

I assume I can use the SB3 uninstall and it will just clean out SB3 and not affect SB4?

 

Thanks for your help partner.... 👍

 

Regards,

Doug

Share this post


Link to post
Share on other sites

It might work, but I can't rule out that some common files may get removed that 4.1 actually needs. So, installing 4.1 over the existing installation (after removing 3.0) would prevent possible problems. No need to uninstall 4.1 first.

Share this post


Link to post
Share on other sites

Well that depends I guess on how often you run the SB 3 sessions?

 

As per the email, maybe those people can help chip in the US$25 each to bring them up to 4.1x?

 

I wouldn't be removing SB3.x until you resolve the heat issue in the other thread.

 

Eventually if you resolve that and only say use the Ver 4.1x versions of the Tutorials, etc. then you shouldn't need too much duplication.

Share this post


Link to post
Share on other sites
2 hours ago, Ssnake said:

It might work, but I can't rule out that some common files may get removed that 4.1 actually needs. So, installing 4.1 over the existing installation (after removing 3.0) would prevent possible problems. No need to uninstall 4.1 first.

 

Hmmm.... maybe I'll let sleeping dogs lie and not do anything right now. 🤔

 

Thanks for the warning ..... ☺️

Share this post


Link to post
Share on other sites
3 hours ago, Gibsonm said:

Well that depends I guess on how often you run the SB 3 sessions?

 

As per the email, maybe those people can help chip in the US$25 each to bring them up to 4.1x?

Well, I'm not sure it would be very often now that I have SB4 running.  Besides, our breed are a dying lot and I don't think there's many left at this stage. 😏

Quote

 

I wouldn't be removing SB3.x until you resolve the heat issue in the other thread.

Solved ... see my response in the other thread. 👍 

Quote

 

Eventually if you resolve that and only say use the Ver 4.1x versions of the Tutorials, etc. then you shouldn't need too much duplication.

Never thought about it that way. 🤔  Another reason to leave SB3 installed and use it for play, other than tutorials.

Edited by BadgerDog

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...