Jump to content

4.250, Framerate drop?


Recommended Posts

  • Replies 53
  • Created
  • Last Reply

Top Posters In This Topic

1 hour ago, Captain_Colossus said:

has anyone experienced performance issues with the update? my impression is there has been a significant impact on framerates with the update. scenarios which were rather smooth prior now experience noticeable stuttering.

Yes, I noticed some loss of fluidity, but along with that a new level of quality in the graphics. I cant explain exactly, but something has changed and it looks quite better.

 

Perhaps you need to tweak your graphics settings now.

Link to post
Share on other sites

I noticed a bit of a performance drop. With that being said, I installed ReShade to try it out, and noticed that my FPS value is more consistent now. I get around 62-65, with that dropping to about 50 if I do some crazy stuff like add in a 18,000 meter visual distance on the mission editor, etc. I don't know why it is working (I'm not using any options except for increased clarity) but it does make a *slight* difference.

Link to post
Share on other sites

Would be good to know if it happens in all the scenarios all of the time, or just some of the scenarios, and there generally, or just in some scenes/stages of the battle. the more you can narrow it down the better our chances to find out what caused it.

Another option is that it's hardware and/or driver dependent.

 

I'm sure, if it would happen across the board in all scenarios, our beta testers would have reported it.

Link to post
Share on other sites
2 hours ago, Ssnake said:

Would be good to know if it happens in all the scenarios all of the time, or just some of the scenarios, and there generally, or just in some scenes/stages of the battle. the more you can narrow it down the better our chances to find out what caused it.

Another option is that it's hardware and/or driver dependent.

 

I'm sure, if it would happen across the board in all scenarios, our beta testers would have reported it.

For me, it's all the scenarios all the time

 

Oddly, not in the scenario editor, in 3d mode.

 

Link to post
Share on other sites

after i installed the update, i immediately set to rule out i either i had some malware running slowing down the system, or  perhaps that i had two instances of steel beasts running at the same time; in the mission editor, there is a heavy feel pressing the WASD keys in free move mode when scanning around the terrain, as if the POV camera is dragging a heavy weight along with it.

 

i am not sure the graphics alone are the issue: subjectively, other than some texture changes to individual objects, the engine looks the same if not similar to what it was before. the difference is how much slower scenarios are running, and this is noticeable in all but the very smallest scenarios with limited objects and viewing distances such as instant action.

 

on a custom map and scenario, i estimate the frame rates are maybe half of what they were before; paring down the viewing distance, shadow mapping, turning down anti aliasing to the lowest setting and removing large sections of forest from the map were unconvincing in a small performance gain. in this scenario before it was the large number of units, particularly infantry which were the bottleneck, as these units were killed and removed, the scenario tended to speed up over time- not this time however after the update.

 

while all this is preliminary and sketchy, it seems as if the hardware went backwards maybe a generation in trying to keep up with the software (my machine is a year and half old, top of the line hardware when i bought it then). i have a few hours a week i can run steel beasts, i'll keep looking for patterns which may be related to it.

 

 

Link to post
Share on other sites

Well then, what are your graphics cards, and which driver versions do you use?

The NVidia Control Panel should provide answers to these questions (unless you're using an AMD card, of course).

Link to post
Share on other sites

Nvidia GeForce RTX 2080 Ti; latest drivers.

 

generally steel beasts was running smooth across the sorts of scenarios i tend to run; as noted the difference came with the update; even scaling down graphics  wasn't really worth the slight gain in FPS.

Link to post
Share on other sites

As stated, I've taken a huge hit in FPS with this last patch. Was running perfectly with GFX maxed last patch. Now hardly able to maintain 60fps even on low settings.

 

Win 10

I7 3.5ghz

GeForce 1070 (Latest drivers)

16gb RAM

 

1920x1080 Desktop Resolution

In-game: Windowed

 

 

 

 

 

 

 

 

 

Edited by Apocalypse 31
Link to post
Share on other sites
2 hours ago, Apocalypse 31 said:

As stated, I've taken a huge hit in FPS with this last patch. Was running perfectly with GFX maxed last patch. Now hardly able to maintain 60fps even on low settings.

 

Win 10

I7 3.5ghz

GeForce 1070 (Latest drivers)

16gb RAM

 

Ok... And do you run SB in full screen or windowed mode? What are resolution settings?

Link to post
Share on other sites

Well,

I'm running a 12GB RAM , 3,4 GHz Processor Widnows 10 system with a NVIDIA 1070 graphics card.

 

It has been running in the 40s FPS wise before and after the update...

I do get a FPS hit when using the Piranha V tough

Link to post
Share on other sites

With a risk of walking into a minefield (I admit that I don't always read all the replies)...

 

Speaking of system performance in 4.250...

 

One thing that would help, regarding performance comparisons, is if someone had both version of SB installed (4.167 and 4.250) and run the same scenario on both, observing in the same location, with the same exact ALT+D and ALT+G settings, for an actual fps number comparison.

 

Otherwise, just saying that performance is worse doesn't help a lot, unfortunately. I know its a lot to ask, but its the best way to get a direct comparison to help narrow things down (to % performance difference). 

 

 

Link to post
Share on other sites

FULL SCREEN (top) VS WINDOWED (bottom)

terrain settings at 20 with 100 preload

 

todays kanium scenerio in single player mode

Performance is poor =10fps

windows 10

AMD cpu and video

4.0 ghz cpu

RX560 4 gig video with todays driver update

32 gig ram

 

and just to put into context performance wise here is  DCS on HIGH settings=30fps

2021_02.07-23_20.png

2021_02.07-23_24.png

 

 

 

 

2021_02.08-00_50.png

Edited by Badger
Link to post
Share on other sites
On 2/1/2021 at 3:52 PM, Captain_Colossus said:

has anyone experienced performance issues with the update? my impression is there has been a significant impact on framerates with the update. scenarios which were rather smooth prior now experience noticeable stuttering.

 

No appreciable drop here, either with Testing in Mission Editor or Hosting Multi player sessions

Link to post
Share on other sites

So far, we're "not seeing it". There were no code changes that have the potential to make a big difference; if at all, 4.250 is running faster on the developers' machines (if only slightly). We need more details from you, driver versions (be specific), card models, screenshots of scenes where you have low frames (so maybe it's related to objects in the scene). If you have reduced framerates while looking at the sky, that would be an important clue as well (but probably there won't be differences).

Link to post
Share on other sites

Testing with the attached scenario:

 

Periscope, wide angle:

 

4.167: ~62.5 FPS

4.250: ~18 FPS

 

Periscope, narrow angle:

 

4.167: ~50 FPS

4.250: ~24 FPS

 

Commander, unbuttoned:

 

4.167: ~42 FPS

4.250: ~27 FPS

 

Fullscreen, vsync off, same (default) graphics and terrain settings on both Steel Beasts versions. Video card is GTX 1660 Super, 461.51 drivers. CPU is i7-860 @ 3.4 GHz, 16 GB RAM. Windows 10 Pro 20H2. 

 

SB_4167_wide.thumb.jpg.b3be2d0b3ee5e8cdb1a2547398c6eb7b.jpg

 

SB_4167_zoom.thumb.jpg.4ee01156ef5089d333bb9eb673665779.jpg

 

SB_4167_cmdr.thumb.jpg.f7b73d3a7afee3b06f150247ddebcac9.jpg

 

SB_4250_wide.thumb.jpg.33d6c5191e5030475ec74ddb5e7a0bb6.jpg

 

SB_4250_zoom.thumb.jpg.f7fe95d4b0d62c745e91a77a79968dc7.jpg

 

SB_4250_cmdr.thumb.jpg.e4e6cbcfed11873a0766862a741891ad.jpg

 

SB_settings.jpg.01cceb2f69591e01eb4d51b50100d37c.jpg

 

 

 

 

FPS_test.7z

Edited by Rotareneg
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...