Jump to content

X56 Joystick not recognized in game


Recommended Posts

Hi everyone,

I am having an issue with getting the game to recognize my HOTAS (X56). I have a Logitech 3D Pro, and if I connect that, it works fine. However, my Saitek X56 is not recognized on the key binding. I sees the device, but none of the buttons will map in the controller setup up screen. The only other option I have not tried is to map all the keys with the Saitek Programming software. Any ideas you can throw my way to try.

Link to post
Share on other sites
Posted (edited)

Welcome.

 

Whilst not directly related (in that you are talking about a different controller) this may help:

  

On 2/15/2019 at 6:36 PM, Ssnake said:

I don't think it's the controller per se, but the question is which one is registered under Windows as the "preferred device".

For Windows 10: Hit the Windows key once, type in "Gamecontr" to start the Gamecontroller app. There you'll see the list of devices registered as a game controller (e.g. in my case, it's ALSO listing the mouse, which may be counterintuitive). Click the button "advanced properties..." or whatever it's called in English Windows versions (mine is German, sorry), then select the joystick that you want to use with SB Pro.

 

If you don't want to use a gamecontroller at all: In Steel Beasts you can open the "Controls" dialog from the main menu (or hit Alt+C at pretty much any time). In the upper left corner there are radio buttons to select either Joystick, or Control Handle input; below them is a box to "Disable Joystick input".

 

 

Edited by Gibsonm
Link to post
Share on other sites
41 minutes ago, Gibsonm said:

Welcome.

 

Whilst not directly related (in that you are talking about a different controller) this may help:

  

 

 

Hi Gibsonm,

yes I tried that as well. It does show my controller as preferred device. Tried with just the stick and not the throttle as well, no change 😕

Link to post
Share on other sites

I'm not a Saitek expert. The fact that the Logitech stick works suggests that Steel Beasts does recognize a valid joystick signal. So the question is, what's the difference between the Logitech and your Saitek stick that the former generates a signal that Steel Beasts can process while the latter doesn't.

SB Pro only accepts signals from the preferred device. So if the Logitech one works, I suppose it is the preferred device. Are you sure that the Saitek is configured correctly?

Link to post
Share on other sites

Yes, 100% positive. I use the X56 mostly for my DCS flight sim games, but it works fine with other games (Arma III, Enemy Engaged, Flight Sim 2020, etc.). SB will not detect any axis movements or buttons. So now i'm stumped.

Link to post
Share on other sites

I don't doubt that either stick works.

But the by far most likely reason that one is being recognized by SB Pro while the other is not is that only one of them can be the preferred device. Did you unplug the Logitech stick before testing the Saitek? Have you accessed the Saitek's Advanced Properties and set it to be the "preferred device"?

Maybe try logging off from Windows, and then logging on again. This gets most services restarted, maybe it helps with the recognition of the device.

 

The next question is the joystick settings in Steel Beasts. Maybe the axes are assigned wrong, or the checkmark is set to use a palm switch or something like this?

Link to post
Share on other sites
6 hours ago, Ssnake said:

I don't doubt that either stick works.

But the by far most likely reason that one is being recognized by SB Pro while the other is not is that only one of them can be the preferred device. Did you unplug the Logitech stick before testing the Saitek? Have you accessed the Saitek's Advanced Properties and set it to be the "preferred device"?

Maybe try logging off from Windows, and then logging on again. This gets most services restarted, maybe it helps with the recognition of the device.

 

The next question is the joystick settings in Steel Beasts. Maybe the axes are assigned wrong, or the checkmark is set to use a palm switch or something like this?

Hi Snnake,

Actually, you and I have conversed in the recent past via email on this topic:

 

Quote

Hello Paul,

Monday, March 22, 2021, you wrote:

PH> Ever  since  the  latest  patch, my joystick is not recognized. It
PH> worked  fine  in  all  previous versions, but not any longer. I've
PH> re-installed  the  game,  updated  all drivers and Win 10 updates.
PH> This  is  the  only game the HOTAS is not recognized. Is there any
PH> direction you can provide. I'd appreciate it

I  can  assure you that we haven't suddenly decided to hate the X56. I
don't  think  we  have made changes to the code base lately that would
change the way we're handling joysticks.

SO, I have only general directions to offer.

Is  your  stick  still  the  "preferred  device"  per  Windows's  Game
Controller settings (advanced properties)?
Has  Joystick  input  been  disabled,  per chance, in the Steel Beasts
"Controls" dialog (Alt+C)?
Does  the  strick  still work in other games/is it still recognized by
Windows,  does  it  respond  in  the  calibration function of the Game
Controller settings?

I  hope  that one of these hints helps you to guide your investigation
in  a  useful direction. Please let me know if you come up empty, so I
can pass on your case to the programmers for comment.

Sincerely yours,


Nils "Ssnake" Hinrichsen
Director
eSim Games Deutschland GmbH

 

I've tried just having the Stick and disconnecting the Throttle stick.. same issue. I unplug and plug in the 3D Pro.. works just fine 😕

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...