Jump to content

Issue with Maps


Nike-Ajax
 Share

Go to solution Solved by Jartsev,

Recommended Posts

Hello

I feel like I am missing something obvious - so bear with me please ...

In the last few MP sessions after I updated then I have a map issue and get this message:

unknown.thumb.png.142d977f620d8a3c4ea87c4592058849.png

 

I am certain that the error is at my end as no other seem to have it.

 

I am just unsure as how to correct it ?

Any help appreciated - tnx

Link to comment
Share on other sites

First of all,  are you sure, that map is already present on your computer and was not deleted for whatever reason? It is worth to double-check this. Then next question, if  path to the folder containing maps is correct.

 

Edit:

1) note, that in particular case delta package appears to be missing, and there is a known issue with host unable to transfer  deltas to clients

2) Do you have Map Transfer Manager installed? Is its  version  up-to date (V48)?

Link to comment
Share on other sites

  • Members

With the Map Package Transfer Manager running, typically it would automaticvally start looking look for the map on a map server. If you have the Map Package Transfer Service disabled in your Windows / Services dialog, you can at least when you get the message click on the button in the lower left to copy the Map UID, and then start the Transfer Manager manually, paste the UID there, and start the trasfer manually.

Exit the dialog, then enter it again, and the problem should be gone. IF the map in question actually IS available on one of the Map Servers that you have configured (by default, it checks at least the eSim Games map server, but some  Steel Beasts communities/virtual units may have set up their own map servers (and you might want to add their IP addresses/server names, if you play with them on a regular basis).

 

Find the Transfer Manager's user's manual below.

MapPackageTransfer.pdf

Link to comment
Share on other sites

On 11/29/2021 at 4:15 PM, Jartsev said:

First of all,  are you sure, that map is already present on your computer and was not deleted for whatever reason? It is worth to double-check this. Then next question, if  path to the folder containing maps is correct.

 

Edit:

1) note, that in particular case delta package appears to be missing, and there is a known issue with host unable to transfer  deltas to clients

2) Do you have Map Transfer Manager installed? Is its  version  up-to date (V48)?

 

Thank you Jartsev - I have just dived into the files on my hardrive so under C:\ProgramData\eSim Games\Steel Beasts\maps

 

And they all seem to be there. So maybe its a conflict or I installed it wrong or I need to configure something ?

 

So how do I doublecheck the path  and if needed change it ?

 

I have had this issue a long time ago. And I seem to recall it was something about have two different versions of the map tool(s) installed ?

 

Link to comment
Share on other sites

  • Solution

It is  hard to say what exactly went wrong  in your case, and I'd prefer not to make guesses here. Still you need to address the situation somehow and I'll suggest to check if  maps folder from your previous installation is still somewhere else on your computer(e.g. on  other drive, for example), unless you always utilized  default location C:\ProgramData\eSim Games\Steel Beasts\maps.

 

If there  is an old folder found somewhere, you can define it as a new  file path  for maps:

1) Make sure  that it contains 'Default' map package; if not-  copy-paste it there, since SB would not run without it.

2) Launch SB as  administrator (right click on shortcut> More...>Run as Administrator)

3) In the Main Menu pick 'Options', then  'File paths' and check  what address is listed there; probably it would be C:\ProgramData\eSim Games\Steel Beasts\maps

4) Change location of map package folder by left-clicking 'Map Package Folder' line- dialog will pop-up,  navigate to required folder and confirm your selection by clicking 'Select' button

 

If there no such  old folder found for whatever reason,  I'll suggest to re-install everything starting with SB Maps first, then SB Pro PE itself, and Map tools as a final touch. Running maps installer when everything else is already done was causing issues to some people in the past, so complete re-installation is a very time-consumable, but probably a safer option.

 

P.S.

It is also  worth to keep in mind, that optional Legacy Maps Installer places pre-4.1 maps only to C:\ProgramData\eSim Games\Steel Beasts\maps.

 

Link to comment
Share on other sites

  • Members

Steel Beasts shows the path to the map files that it uses under Main Menu ... Options ... File Paths

You should then compare the contents of that folder with the one you thought you were using. Then copy one into the other, skip all identical files, and then either change the file path (if you copied from the current location to the desired folder), or leave things the way they are (on startup, SB will scan the contents of the map packages folder, and recognize the added maps).

 

Once that you're confident that the file copy process was successful, delete the other folder, and you're done.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...