Jump to content

Steel Beasts Map Transfer Manager..error


Pipe
 Share

Recommended Posts

  • Members

There's still an instance of the software active. Should no longer happen (since about 2018) but apparently still does, on occasion.

 

Anyway, find all instances in the Task Manager, and end the processes there, then start again.

Link to comment
Share on other sites

 

 

13 hours ago, Sean said:

For anyone else that stumbles upon this, either stop the map package manager service first, or "run net stop SBMapPackageDownloadService" from the command prompt to stop the service.  Then delete the mutex and restart the service.

 

I:

 

1. Stopped the service.

 

2. Tried to run the cmd line instruction:

 

image.png.1e18a95959b593be4995da8973838996.png

 

I guess this failed because I had stopped the service already?

 

3. Went to C:\ProgramData\eSim Games\Steel Beasts Map Transfer Tools\IPC to delete the "mutex" file but there wasn't one.

 

4. Then tried to restart the Steel Beasts Map Transfer Manager (double clicked or do I need to somehow manually load it in the task manager?) and it indicated it was "disconnected" clicking on "connect" resulted in:

 

image.png.57af04d31e78ff9e5e9b8819122eb19c.png

 

Link to comment
Share on other sites

I am having some trouble with Kiev E and W, Cherson and Oksboel.

 

They download ok but don't show up in the mission editor despite refreshing the list.

 

They can be opened in the map editor and saved as new packages and published under new names. After I do that they show up as selectable in the mission editor.

 

Any ideas?

Link to comment
Share on other sites

I know that there's two Oskboels. One is classified as an "autocreated base map" and the other is a delta for it. The delta map is the one that has been prettied up by @DK-DDAM

 

I'll see if I can find the UID for the delta.

 

Edit: The UID for the delta is 7e0e7e2e-27c9-4aad-9a85-8974d8496cd5

Edited by TankHunter
Link to comment
Share on other sites

1 hour ago, RomeoNovember12 said:

I am having some trouble with Kiev E and W, Cherson and Oksboel.

 

They download ok but don't show up in the mission editor despite refreshing the list.

 

They can be opened in the map editor and saved as new packages and published under new names. After I do that they show up as selectable in the mission editor.

 

Any ideas?

When you  are picking map,  default filter option is a 'Published (except autocreated base) maps'. Due to the way how those maps were saved during their creation, please use 'All' or  'Published maps' filter options instead.

Link to comment
Share on other sites

Update:

 

Tried: "net stop SBMapPackageDownloadService" followed by "net start SBMapPackageDownloadService"

 

Task Manager says its running.

 

No "mutex" file to delete.

 

Tried to launch the Steel Beasts Map Transfer Manager (V55) still says its disconnected.

 

I presume there is no basic, bullet-proof FTP site or similar alternative?

Link to comment
Share on other sites

On 8/10/2022 at 10:01 PM, Ssnake said:

Yeah, that's not terribly illuminating.

What do the serviceLog.txt files say?

Note that a new file is created whenever the TransferManager service is being (re)started, e.g. after a Windows reboot. An error may only be found in one of the older log files.

 

Sorry busy few days here.

 

Will try to upload the last few days worth in the next 24 hours.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...