Jump to content

If your dongle is not working, please read this


Recommended Posts

If you have Norton Internet Security, please disable it and see if that fixes the problem. (Norton Internet Security seems to block communication to a port that the CM stick uses.) If that fixes the problem, then you need to add the CodeMeter Runtime Server program to the list of programs that the Nortorn Firewall will permit to run. (I'm not certain about this last part, but there should be a way to let Norton Internet Security allow the CM stick to access the port.)

If turning off your anti-virus/Internet Security program does not work, then it's possible (although very rare) that the license is not in the stick. To check this, first, start the CodeMeter Runtime Server with dongle in the USB port. (Start | All Programs | CodeMeter | CodeMeter Runtime Server).

Next start the CodeMeter Web admin program. (Start | All Programs | CodeMeter | CodeMeter Web Administration)

Then click on the Contents button. Next click on Licenses. Now, do you see a license listed for eSim Games? (It should have a firm code of 100146.) If so, and if you click on that firm code number, it will list the product codes. Do you see product code 11051?

If you don't see these things, then please do the following:

  • First ensure that the CodeMeter runtime server is running with dongle in the USB port: Click Start | All Programs | CodeMeter | CodeMeter Runtime Server (either application or service).
  • Right click on desktop and select "New | Wibu Control File."
  • Click on Create.
  • In next dialog box, check the "New Firm Code" box and enter firm code "100146".
  • Click on OK, and the control file will be created on the desktop.
  • Send the file to comments@esimgames.com, along with your Order ID (which was sent in your confirmation email).
  • eSim Games will send back another file.
  • Right click on this new file and select "Update CM-Stick." The CM Stick should now be updated.

Also you may want to upgrade your CodeMeter firmware. Please read this thread to learn more about your options.

Should you be using a 64 bit Vista version, you need the 64 bit CodeMeter runtime software. Download it directly from www.CodeMeter.com

Another popular source of trouble is the Data Execution Prevention.

Right-click "My Computer" and select System Properties.

In the following window, go to the Advanced tab.

Click on Settings of the first item, System Performance

This opens a new window. Now pick the third tab, Data Execution Prevention.

See if it is switched off, or enabled. If enabled, you may want to whitelist the Steel Beasts executable as well as the CodeMeter executable.

CodeMeter technical support also recommends to explicitly install the CodeMeter runtime with administrator privileges. To do so, hold the Shift key and right-click the setup executable, then pick from the context menu "Run as Administratror".

Also, please make sure to uninstall previous CodeMeter runtime versions.

Edited by Ssnake
Link to comment
Share on other sites

  • 1 month later...
  • Replies 304
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Posted Images

I also found out the hard way last weekend that USB extension cables can make a real difference.

Plugging my dongle into such an USB extension cable gave me constant "ding" (USB device recognized by Windows) and "dong" (received USB device disconnect event) events - the dongle was visible for some seconds, then it was gone for some seconds, etc.; sometimes it would stabilize, sometimes it wouldn't.

I've been using that very same USB extension cable for my USB stick, my external USB hard disk, my digicam, my USB multi-card reader, my USB MP3 player without problems since over one year, so the cable was the last thing I suspected.

Yet my SB Pro PE dongle was recognized rock-solid when I plugged it directly into a USB port in my computer's case (had to crawl under the desk for that, that's why I have that extension cable) and even when I plugged it into a somewhat more expensive USB extension cable with shielding (that wire mesh stuff around the cable - you can sometimes see it with transparent cable isolations).

Bottom line: If your dongle is flaky using a USB extension cable, try plugging it into the USB port in your computer's case directly. It might help.

Link to comment
Share on other sites

We wrote to WiBu about this, and they would like to get some information from the CM Stick:

Could you please get me a CmDust-Result.log? If you never have created a CmDust.log please do the following:
  1. Download CmDust
  2. Plug in your CM-Stick(s).
  3. Start the program simply by doubleclick. A console window opens and disappears after a few seconds.
  4. Now you find the results of the analysis in the file "CmDust-Result.log". You can open this file with a normal text editor (e.g. notepad) to see what we have collected.
  5. Please send the file "CmDust-Result.log" to us via e-mail.

Edited for better looks

Link to comment
Share on other sites

Was it the same port that the cable was plugged into? If not, it could be that one port is different than the other.

I checked all USB ports on that machine. The behaviour was consistent with all of them: Dongle directly on the USB port without any extension cable works fine. Dongle on the shielded extension cable works fine. Dongle on either of the two other cables results in that flaky on-off behaviour.

In the meantime, somebody told me that those extension cables might be out of spec - too long for what the USB standard specifies. One way or the other, all other USB hardware I own works nicely with either of them - on three different computers.

Nevermind, one approach that works is good enough for me, and I have that now. ;-)

Link to comment
Share on other sites

  • 2 weeks later...

Message sent. I can't get any of the fixes here to work. I sent a log file. It appears my dongle is erased or something. XP won't recognize it anymore, says, "USB mass storage device not recognized...may be malfunctioning..." Tried other ports, front and back of puter and other devices to ensure the ports were working properly and they are. I included more details in my email. Thanks.

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...
  • 3 weeks later...
  • 2 weeks later...

Just got my SBPPE, and it no workie :( I have followed the above instructions, the firmware updated no problem the game is patched to latest version. When I check the license it's there, the firm code is 100146, but the product number is 11050 not 11051.

When I click on the SBPPE .exe I get this message:

"CodeMeter error: Please ensure your CM stick is securely in a USB port.100146:11051."

I have tried different USB ports, I know they work.

Heeeeeelllllllllp :biggrin:

Link to comment
Share on other sites

  • Administrators

Uhoh, someones been writing licenses with the wrong code. ;-) The good news is that this is easily fixed through email.

Follow the directions in the first post in the thread here: http://www.steelbeasts.com/sbforums/showthread.php?t=7012 and esim will send you back a license that will fix this ASAP.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...