Jump to content
Scrapper_511

v2.640 Bugs

Recommended Posts

Tried the T-72 in Instant action.

Unlimited Sabot rounds but everytime I fire the gun it wont load another round.

Whenever the AI has control it loads just fine.

Yes, unlimited ammo doesn't mean the gun won't have to reload, it just means the ammo supply will never deplete.

Share this post


Link to post
Share on other sites
If you set up a crossing and there are platoons mixed together, then this will definitely happen. Make sure there is good spacing between your platoons and you'll get better results.

Correct, I do get better results, but I still get the occasional straggler drowning himself even when it is just the one platoon in column formation. Anyway, I'm only reporting bugs; though there is no need to respond to my posts I do appreciate the feed back and response none the less. Thanks again for your time.

Share this post


Link to post
Share on other sites

Well, we have to separate real bug observations from those that represent expectations about the user interface that SB cannot or isn't supposed to deliver. For example, if a player would set an assault route across a river in line formation, full speed - it may actually be a desirable outcome to have all tanks drown to death simply to teach the player a lesson that this was really a stupid idea to begin with. Make things too easy and the units too intelligent in their behavior, and the lesson gets lost.

(That's not to say that there isn't room for improvements)

Share this post


Link to post
Share on other sites

Yes, I can understand a line formation of vehicles at full speed plowing into a river and all being taken out of commission. That is why I specifically mentioned a single platoon of vehicles in column formation still on occasion losing a vehicle to a river in my previous posts. I guess I could further iterate that they are under the march command. I usually set it up such that they are going for the bridge at as straight a path as possible, with a point of reference just before the bridge as well as just after the bridge, and making sure if there is an end way point near the bridge that there is more than enough distance from the bridge to bring the last unit across.

I've even had it where after crossing a bridge a vehicle or two will back up into the river to drown itself. This usually, but not always, occurs when they encounter the enemy and the end way point is semi close to the river. Guess they are trying to get hull or turret down in the river. I must say, it is an effective way of avoiding the enemy...

To me it feels like sometimes I have to micro manage each and every unit to ensure their safety from themselves. Some units just seem to go out of their way to drown themselves.

Share this post


Link to post
Share on other sites
Some units just seem to go out of their way to drown themselves.

Maybe talk with HR, or take a look at the field kitchen.. :P

Share this post


Link to post
Share on other sites

LoL, or perhaps they just hate me as their commander. O.o'

"What, he's leading us again?!... You know what, that's it, I'm going to go drown myself and I'm taking this hunk of metal with me."

Share this post


Link to post
Share on other sites

Maybe they need a bit more emphasis on the 3rd law..

1. A robot may not injure a human being or, through inaction, allow a human being to come to harm.

2. A robot must obey the orders given to it by human beings, except where such orders would conflict with the First Law.

3. A robot must protect its own existence as long as such protection does not conflict with the First or Second Laws.

Share this post


Link to post
Share on other sites
Can you test and see if renaming the "Español" folder to "Espanol" will solve the issue for you?

Maybe it's the use of this special character in the file path of your localization package that is somehow involved with it (while other languages that have no non-ASCII character in their file path don't show these symptoms).

Find it here:

C:\Program Files\eSim Games\SB Pro PE\loc

Ok Nils, I am happy :):) to tell you that this is a very good fix for this bug.

I have returned the NON UNICODE PROGRAMS to SPANISH to make the test and did as you told me changing Español by Espanol

Now works great. I can create playable scenarios again.

I will inform the member of our Spanish VU comunity to change that letter as a solution for this disturbing issue.

MOST THANKS!!!!! :biggrin::biggrin::biggrin::biggrin:

Share this post


Link to post
Share on other sites

Okei. So, I have a unit scout through a forest. I make sure to have it go around any bodies of water on the map as I am tired of units drowning themselves. and as I have had units drown themselves on this map, I was particularly careful this time around. This particular body of water is definitely shown on the map, and I had the unit set to avoid the body of water as I get tired of my units submerging themselves. So, I go to take care of other units, come back to this one... wtf?

You're telling me this isn't a bug? The unit is to scout around this body of water. The route I setup is no closer than 100 meters from any body of water, and yet he goes and drowns himself... not even in a platoon... a single unit. The AI doesn't know to avoid water, at the slowest speed, and even on its own. I must apologize, but I do not feel that I should have to babysit every unit from its own idiocy.

SS_00_47_25.jpg.fd6cfa805a106e78746d1e37

SS_00_47_25.jpg.fd6cfa805a106e78746d1e37

Share this post


Link to post
Share on other sites

A different one:

For me anyway using the zoom function ("n") while in the 3D world of the mission planning segment appears to be "one way".

Previously I could "n" to zoom in and "shift n" to zoom out.

Now it seems if I zoom in it retains that degree of zoom (even if I go back to the map and pick a different piece of dirt the view is "pre zoomed" to whatever I had before).

Just me or are others experiencing this (or did you change the keyboard shortcut for zoom out?)?

Share this post


Link to post
Share on other sites
So, I have a unit scout through a forest. I make sure to have it go around any bodies of water on the map as I am tired of units drowning themselves. ... I was particularly careful this time around. ... I had the unit set to avoid the body of water as I get tired of my units submerging themselves. ... wtf?

You're telling me this isn't a bug?

In fact, it isn't. It's a design flaw, yes, and one that we will correct as soon as we can. The problem is that the unit tries to stay on course but makes a detour whenever it encounters a tree. This can lead to substantial course deviations, this is, after all, a forest.

This may bring it to a point where the unit is challenged by a dilemma - to have a 100% likelihood to be blocked by a tree, or to take chances and drive through water with the (slim) hope to somehow find its way out of it.

To a human this appears incredibly stupid, but things like that happen if you are in charge of a horde of brain-dead zombies. Usually they do reasonably well, but under the right circumstances the set of instructions that we and you gave them ... fail. We aren't happy about this either, but giving the units a girlish reaction to cold water isn't the solution either (we tried that, and it caused more severe problems in other places). For a while, you'll have to learn to live with it, I'm sorry.

I hope you can still enjoy Christmas, and have a Happy New Year.

Share this post


Link to post
Share on other sites
For me anyway using the zoom function ("n") while in the 3D world of the mission planning segment appears to be "one way".

Hm. Works for me. :confused:

Others?

Share this post


Link to post
Share on other sites
Okei. So, I have a unit scout through a forest. I make sure to have it go around any bodies of water on the map as I am tired of units drowning themselves. and as I have had units drown themselves on this map, I was particularly careful this time around. This particular body of water is definitely shown on the map, and I had the unit set to avoid the body of water as I get tired of my units submerging themselves. So, I go to take care of other units, come back to this one... wtf?

You're telling me this isn't a bug? The unit is to scout around this body of water. The route I setup is no closer than 100 meters from any body of water, and yet he goes and drowns himself... not even in a platoon... a single unit. The AI doesn't know to avoid water, at the slowest speed, and even on its own. I must apologize, but I do not feel that I should have to babysit every unit from its own idiocy.

Try to remain calm, no one will want to reply to your posts if you are going to get irate. ;)

Anyway, you are going to have to provide more information if you want a helpful explanation (or a meaningful investigation). What kind of vehicle is that under the water? Were there enemies around at the time it went into the water? Can you provide the scenario that you were playing? Can you tell us the map you are using? Are you positive the unit was not on Breach tactics? Was the unit on Top Speed? Was the route along the bank of the river? Is that a little pond there or large body or water? Just about any additional information would be helpful, besides a screen shot of an unknown vehicle under water.

The word "bug" sure does fly around quite liberally these days. Whatever you want to call it, we know the AI pathfinding needs improvement. Everyone that has been around here a while knows this; it is a never ending development/improvement, but in the mean time there are handy ways to minimize the behavior -- there are plenty of posts on this subject if you use the forum search feature.

And yes, you cannot recover a vehicle with an M88 if it is 10 to 20 feet below water (not in the scope of SB anyway).

Share this post


Link to post
Share on other sites
Hm. Works for me. :confused:

Others?

Ah, well, I think he is referring to the continuous zoom (not the step/toggle zoom mode).

Gibson, correct, in the Planning Phase 3D world "N" zooms in and not out -- use "SHIFT+N" to zoom out. The N to zoom in and out is only for the step zoom toggle views (like F8 view), continuous zoom in and out is always done with N and SHIFT+N.

Share this post


Link to post
Share on other sites
Ah, well, I think he is referring to the continuous zoom (not the step/toggle zoom mode).

Gibson, correct, in the Planning Phase 3D world "N" zooms in and not out -- use "SHIFT+N" to zoom out. The N to zoom in and out is only for the step zoom toggle views (like F8 view), continuous zoom in and out is always done with N and SHIFT+N.

Yes got that.

Have no problem at all once the mission starts and I'm in say F6 or F7 and "n" toggles magnification "on" or "off".

Its in the Planning Phase.

For me anyway, hitting "n" progressively increases the zoom. "Shift+n" does nothing (no unzoom / reduced zoom).

Share this post


Link to post
Share on other sites

Concerning drowning units:

Phew, glad to hear it is a known issue and that it isn't only happening to me. It just seems odd to me that units would actively avoid a known minefield, but would seemingly; blatantly drive into a body of water out of the blue, effectively decommissioning the non amphibious units. I don't suppose the script for mine avoidance could be used for water when non-amphibious units are going slow enough?

For the mean time though, I will definitely manage. I had already added the recovery vehicle to the mission to recover semi-sunk units, that's when a unit decided to go and completely submerge itself. >.<'

Thank you for the great work you are doing. May you and yours have a wonderful holiday!

Share this post


Link to post
Share on other sites
Just check what it's set to in the Controls. It might be something different.

Right, you may have mapped it to something else. In the controls list, look for "Zoom out" (which incidentally is right after "Toggle mag. / zoom in").

Share this post


Link to post
Share on other sites
Concerning drowning units:

Phew, glad to hear it is a known issue and that it isn't only happening to me. It just seems odd to me that units would actively avoid a known minefield, but would seemingly; blatantly drive into a body of water out of the blue, effectively decommissioning the non amphibious units. I don't suppose the script for mine avoidance could be used for water when non-amphibious units are going slow enough?

For the mean time though, I will definitely manage. I had already added the recovery vehicle to the mission to recover semi-sunk units, that's when a unit decided to go and completely submerge itself. >.<'

Thank you for the great work you are doing. May you and yours have a wonderful holiday!

Yes indeed, it is a constant work in progress. It was very bad about five years ago (regarding water), but it has made incremental improvements. We recently made improvements with pathfinding around signs, fences because it was a huge frustration to the community. It is progress, and we know it still has a long way to go. :)

But really, there must be more to the issue than meets the eye. I tested it (yes we do check everything reported), and I can't get a non-amphib vehicle to go into the water on scout tactics. Try the attached scenario. In the scenario, there is one M2 Bradley on a scout route that goes *through* a pond. Start it up in Mission Editor in Test mode and press F12 (time accel) and watch the bradley drive all the way around the pond. Of course it exhibits questionable behavior with the zig zagging, but it is doing that because it is "feeling" the route to see if it is OK to go back towards the waypoint. We hope to improve that part of the behavior (zig zagging) over time.

So this makes me wonder, perhaps the vehicle type in your scenario may have a behavioral problem. What vehicle was it at the bottom of the water? Or maybe it was along a river and it drove along the river for quite some time?

Share this post


Link to post
Share on other sites
Just check what it's set to in the Controls. It might be something different.

OK, I'll check but I haven't touched the controls between 2.552 and 2.640.

Anyway that's something for tomorrow.

Off to supervise present opening.

To those I didn't catch at TGIF yesterday - Merry Christmas to all and I hope the Mayans are wrong about 2012! :)

Share this post


Link to post
Share on other sites

Gremlins! :)

Got no idea how but "zoom out" was mapped to shift+L, put it back and now all is good.

Move along, nothing to see here. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...