Jump to content
Floydii

Random Pausing in BETA

Recommended Posts

I've been playing the Beta over the last couple of days and have noticed an annoying and sometimes lethal problem.

Every now and again (every couple of minutes at least), the game seems to pause for 2-5 seconds. However, the pause is only as deep as the 3D movement/clicking in the map screens. The underlying mechanics appear to continue onwards, which is the killer (especially when in shootouts with other AFV's). Other than this, the game runs absolutely fine.

The pause only seems to affect the game in progress and not the shell menu.

I am running SB Pro on a Dell XPS1530 laptop with:

2gb RAM

2.0 GHz Dual core Centrino processor

256meg Nvidia Geforce 8600M GT

and Vista as an OS.

I'm thinking RAM pauses due to the rather high vista overhead, but the fact that the game continues onwards while the visuals/input is frozen makes me suspect it might be something more.

Any Ideas?

Share this post


Link to post
Share on other sites

virus? antivirus? spyware that phones home?

tray bar applications?

didn't have any pauses running vista with my 7900, but then again i've heard theres some issues with the drivers on the 8000 series cards, and stuff about the basic vista drivers being über-sucky.

you might want to try and update your drivers first(if you're not running the latest drivers already), then check if your antivirus is updating while playing.

also check the task manager "processes" tab, and see if theres any processes thats taking up CPU or memory while SB is running.

Share this post


Link to post
Share on other sites

In racing simulations, some people with mobile processors have problems with the power-saving features. Apparently, with some simulations the processor believed that it was not being fully used and reduced its speed accordingly (to save power) and causing stutters.

There is an application that fools the processor into thinking that it is being fully used all the time... unfortunately I can't remember what it's called.

It's strange that only the 3D stops, though. I wouldn't be surprised if it has something to do with Vista, though. I have Vista myself and hate it. :decu:

Share this post


Link to post
Share on other sites

Well i get them from time to time but they are much shorter but just long enough to notice it. I cant say it affects my gameplay in a negative way though. I allways stop all programs when i start steel beasts or other stuff than needs some power and i still get them.

Share this post


Link to post
Share on other sites

With a dual-core CPU, background processes can almost be ruled out as the source of throuble. Yet, a shared IRQ or some DHCP process trying to find his domain controller or something like that might also be a source of trouble.

If it happens in regular intervals, and if the freeze is over after approximately the same duration every time, it's likely to be a periodic check of some obscure service that times out after a while.

Share this post


Link to post
Share on other sites

Cheers for the pointers All.

Usually I run a pretty tight ship, process wise, on my PC's. Like I said this thing is a Dell Laptop with a new operating system so I haven't quite beaten it into shape yet. I'll cull some crap from the active processes and see what happens.

Thanks again.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...