Jump to content
RogueSnake79

How to install skins

Recommended Posts

I'm not familiar with DXTBMP, so if you're unsure how to use that software, you might need to seek out their support people.

 

A quick web search seems to indicate the software allegedly does work with .dds, so, in theory, it seems you could edit/create SB skins with it.

 

You say you save the project as a BMP without exporting, then change the compression to DXT5. 

 

First, I'm confused about why you're saving as BMP (bitmap) when you want DDS (Direct Draw Surface). If the software gives you the option, try exporting your project as a DDS. Important step: You must "flatten" it first. (Merge all of the layers into one texture). Of course, save a copy of your project with layers so you can make changes.

 

Second, DXT5 is good for when you need alpha channels (transparency) but is not necessary on the M1 skins. DXT1 is sufficient (and smaller).

 

Third, since the skin you downloaded to modify is in bitmap format, you should make sure it will actually fit the current M1 model. BMP hasn't been used in the sim for a very long time.

 

And lastly, whether you can see it in-game depends wholly on whether you put it in the right folder. Make sure you're doing that, first.

Share this post


Link to post
Share on other sites

I have a question on skin/camo change for infantry units (version 4.x and upwards). For example: I have modified the russian DDS files for the infantry found in textures/camo/woodland/ru folder and saved the edited versions into mods/textures/camo/woodland/ru. In the scenario editor I have changed the camo pattern for "RU", however once I play the scenario the original textures are displayed not the modded one.

 

It seems like it's not usning the skins from the mods folder but from the normal textures folder. Am I putting it into the wrong place or not ticking something in the scenario editor?

 

Edited by daskal

Share this post


Link to post
Share on other sites

Your paths seem correct, and there's nothing further to tick in the scenario editor.

 

First, make sure the map theme you are using is woodland, not autumn, winter, arid or desert. (The woodland folder works with spring and summer woodland themes only).

 

Second, double-check that the modded files are in the correct format and named correctly. (Sometimes I've skipped a step exporting, forgotten to flatten, etc ... or inadvertently added a space or other typo in the file name).

 

If all else is correct, sometimes SB just needs to be shut down then reopened to force the change. (This used to happen to me a lot in 3.x ... not so much in 4.x ).

Share this post


Link to post
Share on other sites
5 hours ago, Splash said:

First, make sure the map theme you are using is woodland, not autumn, winter, arid or desert. (The woodland folder works with spring and summer woodland themes only).

Bingo - I had to refresh the theme using one of the new woodland themes and it worked!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...