Jump to content
RogueSnake79

How to install skins

Recommended Posts

I'm pretty sure that I know how to download and file skins. Lately, however, I'm experiencing a few problems. While I've been able to get successful results with Leo 1A5, Challenger and Leopardo skins, Leo 2A4 and T-72 skins don't seem to want to play the game. I've got them into the proper files, they appear to be 2.640 compatible, but (in the Leo 2A4, for example) all I get displayed is what I think is the default skin: German markings, "722" coding, and a shield device on the rear of the turret. I've got SB v 2.640 installed. This doesn't affect the system, but I'm curious as to why some skins work and others appear not to work. Any thoughts/suggestions will be most welcome!

Share this post


Link to post
Share on other sites

What you're seeing are the "decals", which are applied to the model no matter what skin you use. If you don't want those markings, you'll need a decal file (either blank or with different markings) in your mods folder along with your new skin.

For the Leopard 2a4, the file in question is leo2a4decals.dds.

Do this: Make a copy of fuchs_decals.dds from the "Red" folder in your game's main "Woodland" folder. This is a blank file. Rename it leo2a4decals and drop it in whatever MODS folder you have your new leo skin in. That will give you a decals-free tank.

Share this post


Link to post
Share on other sites

Splash, many thanks for this information: it's one apect of SB that I hadn't seen before. And I'm sure that there are others...! :)

Share this post


Link to post
Share on other sites

Still no go on some of these skins. They must be older versions, not compatible with 2.640. No biggie, I'll just use the defaults for the time being: they drive and shoot just as well! :)

Share this post


Link to post
Share on other sites

I have a specific question regarding CZ Studios' Russian BTR-80 skin: http://www.steelbeasts.com/Downloads/p13_sectionid/297/p13_fileid/927

I have downloaded this skin and placed it in the Mods folder and it doesn't work. I've also tried replacing the default skin in the program folder and it doesn't work there either; all other skins work as expected. I can only assume it's something to do with it being a .BMP file that means it isn't recognised, as all other skins seem to be .DDS format these days.

Does anyone have any ideas as to why this particular skin doesn't work?

Cheers

Share this post


Link to post
Share on other sites
*.DDS files take precedence over *.BMP files, so the BTR skin in question needs to be converted and in fact I did it to that very same skin yesterday.

Here you go.

Thanks very much MAJ_Fubar, that's awesome! The .DDS conversion works a treat and plugs a major hole in my OPFOR tri-colour camouflage collection.

I'm very glad I asked. Thanks again.

Share this post


Link to post
Share on other sites

Hi guys total noob here so please bear with me. :)

I am having a little trouble getting skins to work,and I think I have them in the right place.

I have read all posts in this thread a few times and still can't get it to work.

First I D/L the M1A1 Desert (2.640) by Captain_Colossus

I un-rared the file to reveal some files,

I put the track,roof,decals,M1A1 files (all dds) in my,

C:\Users\micks\Documents\eSim Games\Steel Beasts\mods\textures\desert

These are the only dds files in this folder,also red folder is there too.

After D/L the Advanced tank range USMC : M1A1MBT Fort Benning sce I still see the green skin and not the desert one.

I also tried a few other desert sce and still don't see the new skins.

I have tried a good few skins and can't get any to show up,so I must be doing something wrong.

Any help with this is greatly appreciated,

Regards,

Mick.

Share this post


Link to post
Share on other sites
Hi guys total noob here so please bear with me. :)

I am having a little trouble getting skins to work,and I think I have them in the right place.

I have read all posts in this thread a few times and still can't get it to work.

First I D/L the M1A1 Desert (2.640) by Captain_Colossus

I un-rared the file to reveal some files,

I put the track,roof,decals,M1A1 files (all dds) in my,

C:\Users\micks\Documents\eSim Games\Steel Beasts\mods\textures\desert

These are the only dds files in this folder,also red folder is there too.

After D/L the Advanced tank range USMC : M1A1MBT Fort Benning sce I still see the green skin and not the desert one.

I also tried a few other desert sce and still don't see the new skins.

I have tried a good few skins and can't get any to show up,so I must be doing something wrong.

Any help with this is greatly appreciated,

Regards,

Mick.

You seem to be doing it right.

If your using window 7. my document. esim games. steel beasts. mod folder. textures. make sure You pick the correct folder. desert folder. desert skin.the red folder is For opfor skins one for each folder.

Share this post


Link to post
Share on other sites

cheers Marko,

Yes it is Win 7 I use and as I say I am sure they are in the right folder (not in red one).

I know they are the right ones for my version of SB,ie most recent,I just cannot figure out why I can't get any to show up in game? :(

Regards,

Mick.

Share this post


Link to post
Share on other sites

If the Tanks are green then it's not using a desert theme for the scenario, try a scenario that there would be no question about it using a desert theme, maybe the Easting 73 one that comes with the software and see what skin is used then.

Share this post


Link to post
Share on other sites

Thanks Crusty,

I tried Easting 73 and no joy there either,also in desert ambush as well.

The files in my,

C:\Users\micks\Documents\eSim Games\Steel Beasts\mods\textures\desert

Are T158track.dds, m1a1roof.dds, M1A1.dds, abrams_decals.dds and the folder called red,no other files.

Thanks for your patience guys,

Mick.

Share this post


Link to post
Share on other sites

Have you tried using a sound mod? What happens when you try and use a mod for a woodland or winter pattern?

If these don't work, I would guess that this path is broken:

C:\Users\micks\Documents\eSim Games\Steel Beasts\mods\textures\desert

For some reason, the program isn't finding it, perhaps because the Documents\eSim Games\Steel Beasts\mods\ path is in the wrong root directory.

Perhaps it's this right here: C:\Users\micks

My folders install to C:\Documents - I've never placed them anywhere else.

Share this post


Link to post
Share on other sites
My folders install to C:\Documents - I've never placed them anywhere else.

Just make sure you are talking "oranges" to "oranges" here.

Are you both using the same operating system.

"C:\Documents" for example doesn't exist in Windows 7.

For me at least the Windows 7 path is:

C:\Users\mark\Documents\eSim Games\Steel Beasts\mods\textures

Even though it is also displayed as:

Libraries\Documents

I think XP was something like:

C:\Documents and Settings\Mark\My Documents\eSim Games\Steel Beasts\mods\textures

Share this post


Link to post
Share on other sites

I'm using Windows 7. I don't recall the path to my mods folder looking like that, but I could be wrong.

There are some possibilities:

1) The path to the mods folder is broken, the mods aren't in the appropriate folder, or the installation of Steel Beasts has been corrupted

2) The scenario isn't actually themed for the type of skin expected

3) The file is incompatible with a particular version of Steel Beasts

4) The file name is wrong, like if the file name has been altered or the file type extension removed.

I just can't think of anything else. If all else fails, which I've never encountered, one can copy mods directly into the Steel Beasts directory with all the skins after backing them up. It's riskier than using the mods folder, but not technically more difficult.

Share this post


Link to post
Share on other sites

Cheers for the help guys,

I installed SB in the default folder, ie:

C:\Program Files (x86)\eSim Games\SB Pro PE

I installed the HI RES texture files no problem but didn't like the dust trails so I D/L the back 2 basic ones and they seem to have worked no bother,it just seems that it doesn't want to let me see the skins for some reason.

I will do some more D/L and testing over the weekend and see how I fair.

Will let you know,but I think the outcome will be the same. :(

Thank you,

Mick.

Share this post


Link to post
Share on other sites

Good day Gents,

First of Thanks Gibsonm for you help in explaining the fundamentals on how SB reads skins.

In theory it sounds all good and pretty straight forward, but practically???

It can get frustrating . :Crash:

So I have D/L a new skin.

Made a test map with 1 M1A1 sitting on the turf set the map to Autumn set camo set in the map options to blue, au red , au . Put the new skin in the /esim/my docs/ mod/text/autumn/ au

And nothing there All I can say is OMG! :gun:

Then I did a search on my PC and found another esim folder in Documents folder(maybe got there from my original install of SB some 2 years back . I have win7 with all the same stuff in it as the one in users/my name/my documents/ xx/xx /xx

So I went Arr ha there is my problem its trying to read from two folders so I got rid of the folder in Documents

So all excited thinking I have solved my problem I put everything in the right place fired up my test map and Nothing…

I am up with the play on how to do the Skin its just putting it into the game.

So I still need help trying to get this skinning thing to work.:c:

Thanks

O_Smiladon

Share this post


Link to post
Share on other sites
Is the name of the skin exactly the same as the one you are trying to replace?

Umm not to sure.. I am not really replacing one because in the AU folder there is nothing to replace.

But in saying that do you mean the same as the lone DDs.fil M1A1 that is sitting at the bottom of the country sub groups?

O_Smiladon

Share this post


Link to post
Share on other sites

The file that you put in your mods folder must be the same as the default texture's name. So in this case, it's probably M1A1.dds.

Also, the AU skins only work on the M1A1(HA), not the M1A1, so be sure you are putting the right unit on the map to begin with.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...