Jump to content
Quagmire

Error launching SB Pro PE 3.0

Recommended Posts

OK, I've spent the afternoon/evening trying to find an answer to this - and perhaps a driver that may work.

Well, after narrowing the search 3.0 launched when using Nvidia driver 198.01 - although this isn't a certified one as it came from the laptopvideo2go.com website.

However, hopes were dashed when I clicked on the tank range and was presented with a complete jumble of colours. The menus were fine, as were the briefings but the actual gameplay screens are not, See the attached screenshots to see what I mean. Its the same in full screen and windowed mode.

So right now I've reverted back to 179.48, the one that worked fine with SB 2.654 (and all previous versions).

Haven't a clue what to try next... :frown:

SS_21_19_20.jpg.9bfc21546f4305822bf4cbc6

SS_21_20_58.jpg.fd90b45fea76f5a4b2db1d41

SS_21_22_40.jpg.4331787ee9c6f6af9ffbf7bd

SS_21_19_20.jpg.9bfc21546f4305822bf4cbc6

SS_21_20_58.jpg.fd90b45fea76f5a4b2db1d41

SS_21_22_40.jpg.4331787ee9c6f6af9ffbf7bd

Share this post


Link to post
Share on other sites

Hah. These screenshots indicate that the GPU is simply not capable of properly handling the surface formats which are in use by SB3. Looks like the older driver "knew" about this fact and hence did not offer the formats in the 1st place (as opposed to the newer drivers).

At this point in time, I am unable to tell whether the Go 7950 GTX *should* be capable of using the surface formats or not.

Could you do me a favor and download and run the "Video Memory Stress Test" tool which is available here?:

http://mikelab.kiev.ua/index_en.php?page=PROGRAMS/vmt_en

Just use the default setting (do NOT change vid mode to 640x480 if asked), it will run tests for plenty of surface formats. Maybe it can tell us which format is "broken" for your GPU.

Share this post


Link to post
Share on other sites

Hi dunc, last night and this morning I was playing around with more graphics drivers. I previously mentioned 198.01 that worked (sort of) before reverting back to 179.48 - well, this is where it gets odd...

This morning I decided to launch it 'one last time' and this time it worked (with 179.48), not perfectly but it launched. I went straight to the Graphics menu, and when I moved the anti-aliasing slider forward the game instanty gave me the jumbled colours seen in my previous post.

So, relaunching it I moved all sliders to zero and launched the Tank Range - and I was able to play it - quite smoothly I might add.

I was also able to lauch a few scenarios, namely the introductions to see how the game performed.

Below are 3 screenshots taken randomly testing the graphics. One without any sliders set, one with shadows and the one with anti-aliasing - this messes up the graphics.

Its definitely not perfect, but it did launch. I guess adding and removing countless video drivers had some impact there.

One other error I've seen though is also attached. It popped up randomly but I don't recall the scenario etc. Unfortunately the temporary license I was using was no longer available so I've been unable to test it further today.

I just want to thank Mark Gibson for his help and for the temp license. Cheers Mark! :)

Anyway, I hope the screens and error help. In the meantime I'll run the video test from the link supplied.

Q

56e83cf28472f_NoSlidersSet.jpg.bdaefb6ae

56e83cf287cac_Withoutanti-aliasing.jpg.9

56e83cf28bb22_Withanti-aliasing.jpg.2edf

56e83cf28e09e_NewSBError.JPG.fac17c880c1

56e83cf28472f_NoSlidersSet.jpg.bdaefb6ae

56e83cf287cac_Withoutanti-aliasing.jpg.9

56e83cf28bb22_Withanti-aliasing.jpg.2edf

56e83cf28e09e_NewSBError.JPG.fac17c880c1

Share this post


Link to post
Share on other sites

dunc, the VMT test has finished. The contents of the log file are below. Hope it helps!

Cheers,

Q

[22/09/2013 23:55:04] Test started for "Primary Display Driver (NVIDIA GeForce Go 7950 GTX)"...

Trying 16bpp RGB:565 mode...OK

Trying 16bpp RGB:555 mode...OK

Trying 16bpp BGR:565 mode...NOT SUPPORTED (Code: 88760091)

Trying 32bpp RGB:888 mode...OK

Trying 32bpp BGR:888 mode...OK

[23/09/2013 00:12:22] Pass completed (0 errors found).

Share this post


Link to post
Share on other sites
What's the path to your SB exe file?

Hi Homer, the path is:

C:\Program Files\eSim Games\SB Pro PE\Release\SBProPEcm.exe

Prior to installing 3.0 I did a full uninstall of 2.654, including all folders & files in the Documents and Settings folders for All Users and all other accounts. All mods were also disabled (with JSGME) prior to uninstall, then a clean of orphan registry files was carried out with CCleaner followed by a full system cleanup using the same app.

Q

Share this post


Link to post
Share on other sites

This is a long shot, but I had some luck with this fix when I encountered a similar raster problem. It turned out that windows explorer was causing the error for some reason.

Cut and paste the following into notepad and save it as "test.bat". When you run it, your desktop should shut down and then SB should start up. After exiting SB, hit enter and your desktop should start up again.

taskkill /f /IM explorer.exe

cd C:\Program Files\eSim Games\SB Pro PE\Release

SBProPEcm.exe

pause

start explorer.exe

exit

Share this post


Link to post
Share on other sites

Hi Quagmire,

the VMT results are fine, so they don't give us any further clue.

However, can you confirm that cranking down the graphic sliders in SB solved the issue? I.e. with all sliders at 0 (or rather low), SB works as intended? Or do you still get errors, even with all sliders down?

*If* setting the sliders to 0 solved the issues, we might have some problems with correctly detecting the capabilities of the graphics card. Whether the origin here is the driver or SB itself remains to be seen.

Share this post


Link to post
Share on other sites

Hi dunc,

Previously, after changing video drivers numerous times (before reverting back to 179.48) I was able to launch the game. I tried the tank range first but the images were those in post #26 - jumbled colours.

After launching again (some time later) I checked the Graphics menu and saw that the sliders by default are not at zero, so I set them to zero manually.

I was then able to launch scenarios; namely the tank range and introductions to see how it performed. It was here that I noticed that moving the Shadows too far crashed the game to desktop but up to about level 3 or 4 it worked (but very slowly). The CTD also came with a standard Microsoft error. Moving anti-aliasing one step (to 2) gave the jumbled colours.

I tried it again this morning to test the settings with a couple of maps, one heavily built up and the other a desert, but changing the sliders gave the same results as previously posted.

Right now all sliders are at zero and screen resolution is 1440x900x32.

I've attached a couple of screenshots (jpg format) showing FPS on a small section of the map, they drop by 10fps but still seems playable (fps counter is included in the screenshots for comparison). (Images taken during an artillery attack - lovely sounds by the way! :)) Busy screens though - say with several vehicles visible can reduce the game to a crawl.

@Homer: I can't test the batch file just yet as I can't access the test license. Once Hamachi shows a connection I'll give it a shot.

Q

FPS1.jpg.631e42692010ca86ce93833db9c45a3

FPS2.jpg.d86587c43cc6dd2463f3eb34f3b85af

FPS1.jpg.631e42692010ca86ce93833db9c45a3

FPS2.jpg.d86587c43cc6dd2463f3eb34f3b85af

Share this post


Link to post
Share on other sites
@Homer: I can't test the batch file just yet as I can't access the test license. Once Hamachi shows a connection I'll give it a shot.

Q

Having read this I pinged all the people using my Hamachi connection.

Of the ten connected yours is the only one not responding.

I've also quit and restarted Hamachi - no change.

In all your messing around with Windows you haven't somehow broken your networking?

Share this post


Link to post
Share on other sites
Having read this I pinged all the people using my Hamachi connection.

Of the ten connected yours is the only one not responding.

I've also quit and restarted Hamachi - no change.

In all your messing around with Windows you haven't somehow broken your networking?

Hmmm, I hope not although I haven't made any changes in that area as far as I know. :( I'll check the firewall and do another reboot to be sure.

Right now Hamachi shows grey icons (offline) next to the server connections. Earlier they were blue and indicated they were being 'relayed', but I couldn't start SB3.0 when they were in that state.

EDIT: Mark, I had already set Hamachi as a trusted application on the firewall so that shouldn't be an issue, but after rebooting the laptop Hamachi started and your connection was live but as I watched it Hamachi went offline - clicking the startup button just leaves your connection greyed out for some reason. Do you know if Hamachi is set to time out after a few seconds? That seems to be the problem I'm having, the connection won't stay up. :(

EDIT 2: I just shut down my firewall and A/V and Hamachi still has your VPN as 'no connection'. Very odd...

Share this post


Link to post
Share on other sites
Having read this I pinged all the people using my Hamachi connection.

Of the ten connected yours is the only one not responding.

I've also quit and restarted Hamachi - no change.

In all your messing around with Windows you haven't somehow broken your networking?

I'm at work at the moment, so can't double check, but I went to have a look at SB yesterday evening and got exactly the same Hamachi problems and symptoms as Quagmire, I assumed it was a problem my end and was going to investigate it this evening when I got home, I don't think the problem is your end Mark as my networks were showing no connections to anyone at all.

I wonder if Hamachi has a problem?

Share this post


Link to post
Share on other sites

@Crusty, that's interesting. I've been reading through their forums and a lot of people have raised the issue of Hamachi refusing to go online so maybe it is related.

@Mark, following some advice on Hamachi's site I did a complete re-install of their program and cleared out any existing registry entries etc. I also removed the automatic updates option as that has caused connection issues for some, but when joining the existing network (the one supplied in your email) Hamachi says 'that network appears to be full'.

Share this post


Link to post
Share on other sites
@Crusty, that's interesting. I've been reading through their forums and a lot of people have raised the issue of Hamachi refusing to go online so maybe it is related.

@Mark, following some advice on Hamachi's site I did a complete re-install of their program and cleared out any existing registry entries etc. I also removed the automatic updates option as that has caused connection issues for some, but when joining the existing network (the one supplied in your email) Hamachi says 'that network appears to be full'.

Yes its full because “Lee’s Laptop“ is logged in 3 times. That plus my server plus the other person makes 5 (the capacity).

I’ve deleted the 3 entries for Lees Laptop so see how you go this time?

Crusty same for you.

Please DO NOT change your machine’s name after you log in as Hamachi treats that as two different machines. :)

Share this post


Link to post
Share on other sites
Can't see you on the list.

Have you tried to join (or is this one of those do when I get home jobs)?

It's a when I get home job I'm afraid, about 18.00 UK time.

Share this post


Link to post
Share on other sites
Yes its full because “Lee’s Laptop“ is logged in 3 times. That plus my server plus the other person makes 5 (the capacity).

I’ve deleted the 3 entries for Lees Laptop so see how you go this time?

Crusty same for you.

Please DO NOT change your machine’s name after you log in as Hamachi treats that as two different machines. :)

Thanks Mark I didn't realise that. :) Each time I've reinstalled it Hamachi asks for an account name before it lets me continue to add your network. I'll use the same name as before so this should be the only entry in your list.

Cheers!

Share this post


Link to post
Share on other sites
This is a long shot, but I had some luck with this fix when I encountered a similar raster problem. It turned out that windows explorer was causing the error for some reason.

Cut and paste the following into notepad and save it as "test.bat". When you run it, your desktop should shut down and then SB should start up. After exiting SB, hit enter and your desktop should start up again.

taskkill /f /IM explorer.exe

cd C:\Program Files\eSim Games\SB Pro PE\Release

SBProPEcm.exe

pause

start explorer.exe

exit

Hi Homer, yes I'm able to launch SB 3.0 with this batch file. Curiously though, when I exit SB and return to the desktop Windows Explorer opens soon after.

EDIT: Just ran it again and before it closed I happened to read "taskkill /f /IM explorer.exe 'taskkill' is not recognized as an internal or external command.

This is WinXP Home by the way.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...