Jump to content

Major Performance Drops


OnAlienware
 Share

Recommended Posts

I have drastic drops in performance (from 60fps to 20) occurring during certain transitions in-game. On the tank range, I'll get 60fps in the daysight and gunner's station, but if I go to thermal, then return to either, it'll regularly drop to 20.

I've had the same performance drop transitioning to the "Events" view in the AAR.

Interestingly, using the Windows key to pop in and out of the sim often (temporarily) fixes the issue. The thermal view, regardless, seems to always maintain its FPS.

I'm using Windows 8.1 on an up-to-date Asus G750 (i7, GTX780M etc.) and McAfee antivirus.

Please help! Love the sim.

Edited by FlatTax
Clarity
Link to comment
Share on other sites

Ssnake, thank you for the reply.

I wasn't clear. The thermal view is the only view which maintains my FPS. It's the other views which experience the drop.

I'll go from 60fps in any view, go to thermal and enjoy 60fps, and then have my fps drop to 20 when leaving thermal.

This drop can be triggered by other transitions, too (going to the "Events" view in the AAR, for instance).

Thanks!

Link to comment
Share on other sites

I have a somewhat similar issue. When switching from thermal to day channel there is a significant frame rate loss, which abates after about 1-2 seconds. I would add that performance seems to deteriorate, and this particular issue only rears its ugly head, only after the program has been running for some period of time. For example, I just started SB and jumped into a quick mission, and frame rates were good and consistent between thermal and day channels.

I have experienced the issue using both older and most recent Nvidia drivers.

System info:

Total amount of system memory 16.0 GB RAM

System type 64-bit operating system

Processor: Intel Core i7-2600K CPU @ 3.4GHz

Number of processor cores 4

Total size of hard disk(s) 3726 GB

Disk partition © 1582 GB Free (1863 GB Total)

Media drive (D) CD/DVD

Disk partition (I) 0 B Free (39 MB Total)

Disk partition (J) 866 GB Free (1863 GB Total)

Display adapter type NVIDIA GeForce GTX 580

Total available graphics memory 4095 MB

Dedicated graphics memory 1536 MB

Dedicated system memory 0 MB

Shared system memory 2559 MB

Display adapter driver version 9.18.13.3489

Primary monitor resolution 1920x1080

Secondary monitor resolution 1920x1080

DirectX version DirectX 10

Network Adapter Intel® 82579V Gigabit Network Connection

Edited by MDF
Link to comment
Share on other sites

  • 3 months later...

I had this issue during the last TGIF. My frame rate would often drop for a moment from 30 to around 15 to 25 when switching from the map to the 3D world. I was recording, and thought perhaps that was causing an problem (although it normally doesn't) but it didn't clear up when I stopped to check. Here's the video:

tqU4qoNHRI8

Link to comment
Share on other sites

  • Members
I had this issue during the last TGIF. My frame rate would often drop for a moment from 30 to around 15 to 25 when switching from the map to the 3D world. I was recording, and thought perhaps that was causing an problem (although it normally doesn't) but it didn't clear up when I stopped to check....

Actually, I guess I wasn't paying attention to that part about you saying that you went from the map to the 3D world view. AFAIK (and a programmer will correct me if I am wrong), but it is not abnormal that the frame rate is different from the map and 3D world, and by different, I mean a HUGE difference. The fact is, there is a lot less going on in the map view so you should get extremely high fps there, and the 3D world is of course more indicative to what fps you should expect to have.

For me, I think I have always gotten 60 fps at the map screen and 30 fps in the 3D world, even before any changes to the GFX engine. If you say that you get just 30 fps at the map, then it does make sense that it would be around 15 fps in the 3D world view. What would be a bug is if you consistently get more than that in the 3D world view, and it only dips to 15 fps just after exiting the map, for a temporary amount of time.

Link to comment
Share on other sites

  • Members
Actually, I guess I wasn't paying attention to that part about you saying that you went from the map to the 3D world view. AFAIK (and a programmer will correct me if I am wrong), but it is not abnormal that the frame rate is different from the map and 3D world, and by different, I mean a HUGE difference. The fact is, there is a lot less going on in the map view so you should get extremely high fps there, and the 3D world is of course more indicative to what fps you should expect to have.

For me, I think I have always gotten 60 fps at the map screen and 30 fps in the 3D world, even before any changes to the GFX engine. If you say that you get just 30 fps at the map, then it does make sense that it would be around 15 fps in the 3D world view. What would be a bug is if you consistently get more than that in the 3D world view, and it only dips to 15 fps just after exiting the map, for a temporary amount of time.

Whoops, it seems I am reading too fast lately -- ugh.

So you are saying that the drop in fps in the 3D world view actually IS temporary? If so, then that would be very strange, yes, as long as you are saying the fps raises again while in 3D world view (it is normal that it fps would increase when entering the map though, AFAIK).

Link to comment
Share on other sites

Yes, the frame rate drop when switching from the map to observer view was often only momentary, returning to normal after several seconds or so, and it didn't always happen. I hadn't had this happen (or at least I hadn't noticed it) for quite a while, and then it started again after installing the 340.43 drivers which is what makes me suspicious it might be a driver bug or conflict with something SB does. Tomorrow I'll see if I can get it to happen again with the 340.43 drivers.

Also, I would normally be getting well above 30 FPS, but I use my video capture software to limit the frame rate at 30 fps as that's all YouTube's good for right now anyway. When I stopped recording to see if that would help, I was getting the full ~60 fps on the map, which would then would drop to around 30 or so when I switched to a vehicle before jumping back up to 50 or 60, depending on what was on the screen.

Link to comment
Share on other sites

  • 3 months later...

Hey, gents:

After an absence (and many driver updates), my performance issues are still here, but different. My frame rates rather suspiciously seem to lock in at 20, 30 or 60fps, and the trigger for these rates seems to be changing views.

I love SB. This is killing me. Please help.

Edited by FlatTax
typo
Link to comment
Share on other sites

  • 5 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...