Jump to content

Problem Host games beta 3.019


Recommended Posts

Hi guys!

Need help.

I have a problem when I made a hosted game. The other players cant see my server.

I have Windows 7, and veryfy, ports, firewall an antivirus.

Windows Firewall off

Ports in router open

Karpesky exception firewall for SBPRO64cm.exe

I dont understand, the version 3.011 works well when I hosting games.

Any Idea???

PD: Sorry for my english ;)

Link to post
Share on other sites
The other players were using 3.019 as well?

Yes.Of course.

And if Host one of him, I see his game, but they cant see may hosted game

Only i can host with 3.011.

I dont understand, what made wrong..:mad3:

Edited by Overlord
Link to post
Share on other sites

Same problem here.

I try to host a mission with 3,019, and clients do not see me.

Same session router and pc, if I run the 3,011 and charge the same mission, clients they see the exercice, and they can enter (those with 3,011 obviously).

:icon_frown:

Fresco+

Link to post
Share on other sites

Can you both list what router model you have, and a list of background processes (start the task manager, switch to the Processes tab, sort by name, then make a screenshot). This might help us to figure out if there's something that your two computers have in common.

Link to post
Share on other sites
Router: NETGEAR CG 3100 D
This particular router is a cable modem/router which is known to have portforwarding issues. Not saying that this is the reason for your problems, but you should crosscheck the port forwarding configuration.

Note that the port forwarding requirements for 3.019 are slightly different than they were for 3.011:

You need to forward ports 2300 - 2400 UDP.

One thing to note: plenty of "problematic" routers behave strange when instructed only to forward UDP. You might want to try forwarding ports 2300 - 2400 TCP in addition as well (not because SB needs it, but because some routers won't perform correctly otherwise).

You might as well use a tool like the "PFPortChecker" to test whether port forwarding is indeed working correctly on your machine (note that you must NOT have SB running for testing, as the tool will start listening on the ports you specify in order to check whether the incoming connection is reaching it):

http://portforward.com/help/portcheck.htm

Regarding the "process list" that Nils was requesting: this was a misunderstanding, we don't need the "process list", but the list of listening processes on your machine while SB is running as host:

To get this list, please ALT+Tab out of SB (after starting to host a mission) open an admin command prompt and then execute (substitute your nickname for <yourname>):

netstat -nab > networklist_<yourname>.txt

Please attach the results file "networklist_<yourname>.txt" here for us to check.

Link to post
Share on other sites

The process list can also be interesting to see if there are "unusual" processes in the background that can be found on both machines (like a specific firewall program or so). However, I will check these lists only if they are both sorted alphabetically as stated in my original request.

Right now both are a jumbled mess except for the last image posted.

Link to post
Share on other sites
Problem solved,something was wrong with ports

Yes, with v3.011, I had opened only port 2300 and works perfect.

With 3.019 beta, if activate DMZ the client can see me but cant conect.

Finally opened ports 2300 to 2400 and my host works.:c:

Thanks all !!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...